Bug 461016 - iwl4965 / NetworkManager - system crash on wakeup from suspend
iwl4965 / NetworkManager - system crash on wakeup from suspend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 10:29 EDT by Will Kemp
Modified: 2009-02-15 09:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-15 09:41:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System log extract - messages immediately preceding crash after wakeup (8.27 KB, text/plain)
2008-09-03 10:29 EDT, Will Kemp
no flags Details

  None (edit)
Description Will Kemp 2008-09-03 10:29:51 EDT
Created attachment 315646 [details]
System log extract - messages immediately preceding crash after wakeup

Description of problem:

System locks up on wake from suspend. This doesn't happen every time, but seems to be happening approximately 4-5 wakeups since reboot. 


Version-Release number of selected component (if applicable):

NetworkManager 0.7.0-0.9.4.svn3675.fc9.x86_64


How reproducible:

Apparently random

  
Actual results:

System wakes from suspend but crashes before wireless network is connected. By "crashes", i mean it appears to freeze and no keystrokes appear to affect it.


Expected results:

System should wake from suspend and not crash.


Additional info:
Thinkpad R61
iwl4965
kernel 2.6.25.14-108.fc9.x86_64

An excerpt from /var/log/messages is attached. This is the messages immediately leading up to the crash. After the last message in the attachment nothing else is logged until a hard reboot.

I'm not 100% certain that NetworkManager is involved in this crash - but it appears that way to me from the log.
Comment 1 Dan Williams 2009-02-14 15:20:40 EST
Does this still happen with latest kernel and updates?  Resume from suspend is pretty driver-dependent, and lots of bugs have been fixed in the Intel Pro/Wireless drivers in the last few months.  Latest F9 kernel is '2.6.27.12-78.2.8.fc9'.
Comment 2 Will Kemp 2009-02-14 15:29:43 EST
No, it doesn't still happen. But i've been using F10 since the day it was released and i can't remember when i stopped having the above problem. To be honest, i'd forgotten all about that problem until now.

There is another minor wake from suspend bug with NM, and i guess i ought to report that too now i'm here (it isn't annoying enough to get me doing it so far!).
Comment 3 Dan Williams 2009-02-15 09:41:24 EST
If the wake-from-suspend bug is that NM tries to connect to an AP that was at the location you suspended the laptop, but clearly isn't where you are right now, that's a kernel driver bug that I've just posted patches for this past week.  They should filter down to Fedora kernel updates soon.  If your issue is another bug, and it's significantly different than this one, it would be great if you could file another bug for that specifically so we can keep each bug about one specific defect.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.