Bug 461026 - cups-polld needs to call __res_init() on hostname failure
cups-polld needs to call __res_init() on hostname failure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 10:57 EDT by Tim Waugh
Modified: 2009-01-20 16:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:59:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 2920 None None None Never

  None (edit)
Description Tim Waugh 2008-09-03 10:57:44 EDT
+++ This bug was initially created as a clone of Bug #354071 +++

The cups-polld process needs to call __res_init() before trying to resolve the hostname.

Without doing this, any hostname served by a server on a network interface that is not yet available will fail to resolve even when the network interface becomes available.
Comment 2 RHEL Product and Program Management 2008-09-05 08:43:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Tim Waugh 2008-11-05 05:39:05 EST
To reproduce:

1. On machine A set up a print queue and mark it shared.  Set 'Publish shared printers connected to this system' so that it is accessible on the network.

2. On machine B, use the firewall to *block* UDP port 631.  Configure CUPS to poll from machine A instead, like this:

cupsctl BrowsePoll=machine-a.mynetwork

3. Now on machine B stop CUPS, 'rm /var/cache/cups/remote.cache', and bring down the network interface.

4. Start CUPS on machine B and verify that lpstat -s shows no printers (there is no network connection to do that with).

5. Now bring up the network interface and wait a few minutes, then run 'lpstat -s'.  This should show the remote queue, but the failing package will not because even though the network connection is up, it cannot resolve the hostname due to the resolver cache remembering that there is no connection.
Comment 11 errata-xmlrpc 2009-01-20 16:59:00 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0201.html

Note You need to log in before you can comment on or make changes to this bug.