Bug 46106 - 3w-xxxx/ResiserFS broken in 2.4.3-12
3w-xxxx/ResiserFS broken in 2.4.3-12
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-26 16:41 EDT by Roger Moore
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 10:03:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Moore 2001-06-26 16:41:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686)

Description of problem:
Impossible to unmount a ReiserFS filesystem on a 3ware RAID array.

How reproducible:
Always

Steps to Reproduce:
1. Mount a ReiserFS filesystem sitting on a 3ware RAID array
2. Attempt to unmount the same filesystem
3.
	

Actual Results:  unmount process goes into an uninterruptible sleep and no
other mount/unmount command will work.

Expected Results:  filesystem should be unmounted!

Additional info:

I'm using a Escalade 6000 with 8x80GB disks. The system worked fine with
the previous 2.4.2 kernel. However after the update to the latest kernel
the system refused to unmount the RAID disk and several problems with the
filesystem on that disk manifest themselves (disappearing files etc.).

The problem seems to be fixed in the latest RawHide kernel (2.4.5-0.4) but
that kernel won't compile under 7.1 (even with the gcc update to 88: it
gives a -fno-merge-constants error) and I'd like to disable the
CONFIG_REISERFS_CHECK flag.
Comment 1 Arjan van de Ven 2001-06-26 16:45:57 EDT
Please check bug 45628 for the patch against reiserfs there.
It should make it work again.

Note You need to log in before you can comment on or make changes to this bug.