Bug 461084 - (DAYLIGHT) 2006 DAYLIGHT SAVINGS TIME LOSES 1 HOUR ON RHEL4
2006 DAYLIGHT SAVINGS TIME LOSES 1 HOUR ON RHEL4
Status: CLOSED DUPLICATE of bug 435766
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: coreutils (Show other bugs)
4.9
All Linux
medium Severity high
: rc
: ---
Assigned To: Ondrej Vasik
http://bugzilla.oracle.com/show_bug.c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 22:42 EDT by xiaowei.hu
Modified: 2008-09-04 02:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: coreutils-5.2.1-31.6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 02:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
made a patch for this bug (116.21 KB, patch)
2008-09-03 22:42 EDT, xiaowei.hu
no flags Details | Diff

  None (edit)
Description xiaowei.hu 2008-09-03 22:42:52 EDT
Created attachment 315714 [details]
made a patch for this bug

Description of problem:
uname -a:

 |Linux teradata-etl01.real.com 2.6.9-55.0.0.0.2.ELsmp #1 SMP Wed May 2
 15:06:32 PDT 2007 x86_64

 Problem statement:
 [jwomack@teradata-etl01 rda]$ date --date="20061029" ; date --date="20061029
 1 day"
 Sun Oct 29 00:00:00 PDT 2006
 Sun Oct 29 23:00:00 PST 2006

 [jwomack@teradata-etl01 rda]$ TZ=GMT date --date="20061029" ; TZ=GMT date
 --date="20061029 1 day"
 Sun Oct 29 00:00:00 GMT 2006
 Mon Oct 30 00:00:00 GMT 2006

 Verification:

 Running the script
 #!/bin/bash
 # This shell script reproduces the observed time anomaly
 for TZ in GMT CST6CDT PST8PDT
 do
 echo -e "Timezone: ${TZ}"
 echo -ne "\t"; TZ=${TZ} date --date="20061029"
 echo -ne "\t"; TZ=${TZ} date --date="20061029 1 day"
 done

 reports the PST8PDT time as 23:0:0 instead of the next day.

 Bug diagnosis:

 OEL5 does not have this error.  Also, it is not a tzdata RPM problem because
 I copied the /usr/share/zoneinfo/PST8PDT file from my OEL5 system to the OEL4
 system and can still reproduce the problem.  I suspect it is a glibc problem.

 Impact:

 Batch jobs are processing data that has already been processed resulting in
 duplicate data and errors.


Version-Release number of selected component (if applicable):


How reproducible:

Running the script
 #!/bin/bash
 # This shell script reproduces the observed time anomaly
 for TZ in GMT CST6CDT PST8PDT
 do
 echo -e "Timezone: ${TZ}"
 echo -ne "\t"; TZ=${TZ} date --date="20061029"
 echo -ne "\t"; TZ=${TZ} date --date="20061029 1 day"
 done

 reports the PST8PDT time as 23:0:0 instead of the next day.

Steps to Reproduce:
1.just run the script
2.
3.
  
Actual results:
reports the PST8PDT time as 23:0:0 instead of the next day.

Expected results:
should be the next day time

Additional info:
Comment 1 Ondrej Vasik 2008-09-04 02:05:41 EDT
Thanks for a report, however, it's already reported bug. It is not issue of glibc, it is problem in gnulib getdate.y, will be solved in next maintainance release of RHEL-4 coreutils. Closing as duplicate of #435766 , see that bugzilla for details and upstream commit which solves the issue with daylight saving and relative time offset.

*** This bug has been marked as a duplicate of bug 435766 ***

Note You need to log in before you can comment on or make changes to this bug.