Bug 461097 - Review Request: hunspell-gu - Gujarati hunspell dictionary
Review Request: hunspell-gu - Gujarati hunspell dictionary
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 01:04 EDT by Parag AN(पराग)
Modified: 2008-09-11 12:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 12:57:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
caolanm: fedora‑review+
petersen: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Parag AN(पराग) 2008-09-04 01:04:32 EDT
Spec URL: http://paragn.fedorapeople.org/hunspell-gu.spec
SRPM URL: http://paragn.fedorapeople.org/hunspell-gu-20061015-1.fc9.src.rpm
Description: Gujarati hunspell dictionary
Comment 1 Parag AN(पराग) 2008-09-04 01:05:38 EDT
koji build => http://koji.fedoraproject.org/koji/taskinfo?taskID=804999
Comment 2 Caolan McNamara 2008-09-09 04:26:48 EDT
+ MUST: rpmlint must be run on every package.
  no output

+ MUST: The package must be named according to the Package Naming Guidelines .
  dictionary versioning is tricky as they're generally messy, my own preference is to treat date based releases like pre-releases i.e. hunspell-gu-0.20061015-1 rather than hunspell-gu-20061015-1, but that was clearly not a blocker for hunspell-bn or hunspell-hi so shouldn't be here either.


+ MUST: The spec file name must match the base package %{name}
  yup

+ MUST: The package must meet the Packaging Guidelines .
  yup

+ MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines .
  yup

+ MUST: The License field in the package spec file must match the actual license.
  yup

+ MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.
  yup

+ MUST: The spec file must be written in American English.
  yup

+ MUST: The spec file for the package MUST be legible.
  yup

+ MUST: The sources used to build the package must match the upstream source, as provided in the spec URL.
  yup

+ MUST: The package must successfully compile and build into binary rpms on at least one supported architecture.
  yup

+ MUST: If the package does not successfully compile
  not-relevent

- MUST: All build dependencies must be listed in BuildRequires
  yup

+ MUST: The spec file MUST handle locales properly
  yup

- MUST: Every binary RPM package which stores shared library files
  not relevent

+ MUST: If the package is designed to be relocatable
  yup

+ MUST: A package must own all directories that it creates
  yup

+ MUST: A package must not contain any duplicate files in the %files listing.
  yup

+ MUST: Permissions on files must be set properly
  yup

+ MUST: Each package must have a %clean section
  yup

+ MUST: Each package must consistently use macros

+ MUST: The package must contain code, or permissable content
  yup

+ MUST: Large documentation files should go in a -doc subpackage.
  yup

+ MUST: If a package includes something as %doc, it must not affect the runtime
  yup

+ MUST: Header files must be in a -devel package.
  yup

+ MUST: Static libraries must be in a -static package.
  yup

+ MUST: Packages containing pkgconfig(.pc) files must ...
  yup

+ MUST: If a package contains library files with a suffix ...
  yup

+ MUST: In the vast majority of cases, devel packages must...
  yup

+ MUST: Packages must NOT contain any .la libtool archives
  yup

+ MUST: Packages containing GUI applications...
  yup

+ MUST: Packages must not own files or directories already owned by other packages
  yup

+ MUST: At the beginning of %install, each package MUST run rm -rf %{buildroot}
  yup


looks fine to me
Comment 3 Parag AN(पराग) 2008-09-09 04:49:33 EDT
Thanks for review.

New Package CVS Request
=======================
Package Name: hunspell-gu
Short Description: Gujarati hunspell dictionary
Owners: pnemade
Branches: F-9 
InitialCC: petersen
Comment 4 Jens Petersen 2008-09-09 05:10:41 EDT
./addpackage done, but owner-sync-pkgdb failed with:

OpenSSL.SSL.Error: [('SSL routines', 'SSL3_READ_BYTES', 'sslv3 alert certificate revoked'), ('SSL routines', 'SSL3_WRITE_BYTES', 'ssl handshake failure')]
Comment 5 Fedora Update System 2008-09-09 05:41:04 EDT
hunspell-gu-20061015-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/hunspell-gu-20061015-1.fc9
Comment 6 Tony Fu 2008-09-09 23:12:14 EDT
requested by Jens Petersen (#27995)
Comment 7 Fedora Update System 2008-09-11 12:57:30 EDT
hunspell-gu-20061015-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.