Bug 461112 - Current cman does not conflict with incompatible gfs2-utils
Current cman does not conflict with incompatible gfs2-utils
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cman (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fabio Massimo Di Nitto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 06:08 EDT by Steve Whitehouse
Modified: 2008-09-19 06:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-19 06:23:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Whitehouse 2008-09-04 06:08:18 EDT
Description of problem:

The current cman package does not conflict with earlier gfs2-utils packages despite the fact that it is incompatible with those packages. The spec file need to be updated.

Version-Release number of selected component (if applicable):

[root@men-an-tol steve]# rpm -qi cman
Name        : cman                         Relocations: (not relocatable)
Version     : 2.99.08                           Vendor: Fedora Project
Release     : 1.fc10                        Build Date: Tue 12 Aug 2008 09:50:12 AM BST
Install Date: Wed 03 Sep 2008 03:54:45 PM BST      Build Host: x86-4
Group       : System Environment/Base       Source RPM: cluster-2.99.08-1.fc10.src.rpm
Size        : 2777868                          License: GPLv2+ and LGPLv2+
Signature   : (none)
Packager    : Fedora Project
URL         : http://sources.redhat.com/cluster/wiki/
Summary     : Red Hat Cluster Manager
Description :
Red Hat Cluster Manager


How reproducible:

Every time.

Steps to Reproduce:
1. Install cman from rawhide over an older distro, e.g. f-9 which already has gfs2-utils installed
2.
3.
  
Actual results:

Installs ok, but fails to work

Expected results:

Should refuse to install cman until conflict with earlier gfs2-utils is resolved.

Additional info:
Comment 1 Fabio Massimo Di Nitto 2008-09-19 06:25:55 EDT
As discussed on IRC, partial upgrades from major distro release to major distro release are not supported (or at least i can't find any reference in the Fedora documentation that state differently).

Upgrading from F9 to F10 will pull in the right packages in the right versions.

Anyway if there is a reference that we should support partial upgrades, please let me know because the Conflicts: complexity is way higher than just gfs2-utils.

Fabio

Note You need to log in before you can comment on or make changes to this bug.