Bug 461125 - Upgrade from Satellite 5.0 to Satellite 5.1 sets the ORACLE_HOME different from the documentation.
Upgrade from Satellite 5.0 to Satellite 5.1 sets the ORACLE_HOME different fr...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Mráka
Preethi Thomas
:
Depends On:
Blocks: 446861
  Show dependency treegraph
 
Reported: 2008-09-04 08:46 EDT by Preethi Thomas
Modified: 2008-11-05 13:42 EST (History)
3 users (show)

See Also:
Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:42:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-09-04 08:46:51 EDT
Description of problem:

Upgrade from Satellite 5.0 to Satellite 5.1 sets the ORACLE_HOME to /opt/oracle. different from the documentation.

Version-Release number of selected component (if applicable):
satellite 5.2
rhn-upgrade-5.2.0-11.el4

How reproducible:


Steps to Reproduce:
1.  On a Satellite 5.0 ,Install the rhn-upgrade package
2. refer to /etc/sysconfig/rhn/satellite-upgrade/rhn-satellite-5-upgrade-scenario-1b.txt
3. ./install.pl --upgrade
4.  logout of terminal session & log back in
5. echo $ORACLE_HOME

  
Actual results:
[root@fjs-0-07 ~]# echo $ORACLE_HOME
/opt/oracle


Expected results:

from /etc/sysconfig/rhn/satellite-upgrade/rhn-satellite-5-upgrade-scenario-1b.txt

2. At this point, you will need to log out of your terminal session and
   log back in. Verify that the $ORACLE_HOME environment variable has been
   configured:
      echo $ORACLE_HOME

   You should see: '/usr/lib/oracle/10.2.0/client'

Additional info:
Comment 3 Preethi Thomas 2008-09-08 15:21:24 EDT
I am not sure if the Initial bug is a real issue. I could not reproduce that later.

but with the latest rhn-upgrade package

[root@rlx-3-08 iso]# rpm -q rhn-upgrade
rhn-upgrade-5.2.0-13.el4


Looks like ./install.pl --upgrade fails trying to upgrade from rhel4 satellite 5.0 to rhel4 satellite 5.2

* Installing RHN packages.
Could not install RHN packages.  Most likely your system is not configured with the @Base package group.  See the RHN Satellite Server Installation Guide for more information about Software Requirements.  Exit value: 251.
Please examine /var/log/rhn/rhn-installation.log for more information.


from /var/log/rhn/rhn-installation.log

Installing /var/spool/up2date/libaio-0.3.105-2.i386.rpm...
No updates available for this system
RPM error while handling  The message was:
Failed installing packages: 
('file /etc/oratab from install of oracle-config-1.0-2.el4 conflicts with file from package oracle-devel-9.2.0.8.0-6', (7, '/etc/oratab', 0L))
('file /etc/profile.d/oracle.csh from install of oracle-config-1.0-2.el4 conflicts with file from package oracle-devel-9.2.0.8.0-6', (7, '/etc/profile.d/oracle.csh', 0L))
('file /etc/profile.d/oracle.sh from install of oracle-config-1.0-2.el4 conflicts with file from package oracle-devel-9.2.0.8.0-6', (7, '/etc/profile.d/oracle.sh', 0L))
Comment 4 Michael Mráka 2008-09-09 05:37:50 EDT
It looks like we don't remove oracle-devel package during upgrade. In satellite 5.1 it is obsoleted by oracle-instantclient-config but in 5.2 we move this stuff into oracle-config package which don't do any obsoletes.
Plus update of the default oratab entry ('*') is buggy.

Fixed now.
Sending        misc/oracle-config/oracle-config.spec
Sending        misc/oracle-instantclient/oracle-instantclient.spec
Transmitting file data ..
Committed revision 176714.

oracle-config-1.0-3.el[45]
oracle-instantclient-10.2.0-18.el[45]
Comment 5 Preethi Thomas 2008-09-16 10:18:59 EDT
fails_qa

[root@fjs-0-07 ~]# rpm -q rhn-upgrade
rhn-upgrade-5.2.0-14.el4

Could not install RHN packages.  Most likely your system is not configured with the @Base package group.  See the RHN Satellite Server Installation Guide for more information about Software Requirements.  Exit value: 251.
Please examine /var/log/rhn/rhn-installation.log for more information.


[root@fjs-0-07 iso]# cat /var/log/rhn/rhn-installation.log



Installing /var/spool/up2date/mod_ssl-2.0.52-41.ent.i386.rpm...
No updates available for this system
RPM error while handling  The message was:
Failed installing packages: 
('file /etc/oratab from install of oracle-config-1.0-2.el4 conflicts with file from package oracle-devel-9.2.0.8.0-6', (7, '/etc/oratab', 0L))
('file /etc/profile.d/oracle.csh from install of oracle-config-1.0-2.el4 conflicts with file from package oracle-devel-9.2.0.8.0-6', (7, '/etc/profile.d/oracle.csh', 0L))
('file /etc/profile.d/oracle.sh from install of oracle-config-1.0-2.el4 conflicts with file from package oracle-devel-9.2.0.8.0-6', (7, '/etc/profile.d/oracle.sh', 0L))
Comment 7 Michael Mráka 2008-09-17 05:51:09 EDT
The bug is fixed in oracle-config-1.0-3 (see comment #4) and your compose still contains older oracle-config-1.0-2.

New packages were not tagged for satellite-[54]E-5.2 so they were not in the last compose. Fixed now (re-tagged them).
Comment 8 Brad Buckingham 2008-09-17 13:49:44 EDT
moving to ON_QA.

Composes Satellite-5.2.0-RHEL[45]-re20080917.0 created and pushed to webqa
Comment 9 Preethi Thomas 2008-09-17 15:58:31 EDT
verified
Comment 10 wes hayutin 2008-10-23 11:25:46 EDT
release pending
Comment 11 Brandon Perkins 2008-11-05 13:42:19 EST
5.2.0 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.