Bug 461149 - xorg-x11-drv-i810-2.4.2-3.fc10.x86_64.rpm does not show any text.
xorg-x11-drv-i810-2.4.2-3.fc10.x86_64.rpm does not show any text.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 461185 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 12:06 EDT by Daniel Walsh
Modified: 2008-09-09 06:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 06:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xdpyinfo (2.80 KB, application/octet-stream)
2008-09-04 12:06 EDT, Daniel Walsh
no flags Details
xorg.conf (617 bytes, application/octet-stream)
2008-09-05 11:22 EDT, Daniel Walsh
no flags Details
xorg.log (56.82 KB, text/plain)
2008-09-05 15:46 EDT, Sven Lankes
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 17341 None None None Never

  None (edit)
Description Daniel Walsh 2008-09-04 12:06:08 EDT
Created attachment 315770 [details]
xdpyinfo

Description of problem:

If I boot with xorg-x11-drv-i810-2.4.2-3.fc10.x86_64.rpm drivers I don't see any text, when I revert to previous version the text comes back.
Comment 1 jmccann 2008-09-04 16:14:46 EDT
*** Bug 461185 has been marked as a duplicate of this bug. ***
Comment 2 Matěj Cepl 2008-09-05 05:23:06 EDT
Dan, can we get please your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) attached to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Daniel Walsh 2008-09-05 11:22:02 EDT
Created attachment 315912 [details]
xorg.conf

If I remove the xorg.conf altogether I get no text and no way to even login.
Comment 4 Sven Lankes 2008-09-05 15:46:44 EDT
Created attachment 315930 [details]
xorg.log

I'm seeing the same issue on an i386-system (Asus P5E-V HDMI onboard-graphics). Reverting to xorg-x11-drv-i810-2.4.2-1.fc10.i386.rpm makes the problem go away. All 2.4.3-* versions switch to graphic mode and then show the gdm login window without text and with no working keyboard.

After some mouse movements the following errors show up in Xorg.log (see attached copy):

[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
Comment 5 Ben Gamari 2008-09-06 13:57:12 EDT
I'm seeing this too on an x64 machine (i965). Downgrading fixes the issue. It probably has something to do with https://bugs.freedesktop.org/show_bug.cgi?id=17341.
Comment 6 Ben Gamari 2008-09-08 02:02:03 EDT
This has been worked around in xorg-x11-drv-i810-2.4.2-4.fc10 for EXA.
Comment 7 Sven Lankes 2008-09-08 15:28:12 EDT
Confirmed - 2.4.2-4 fixed the issue for me.

Note You need to log in before you can comment on or make changes to this bug.