Bug 461160 - AttributeError: KickstartData instance has no attribute 'encrypted'
AttributeError: KickstartData instance has no attribute 'encrypted'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pykickstart (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
http://rhts.redhat.com/cgi-bin/rhts/j...
: TestBlocker
: 461287 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 12:54 EDT by Jeff Burke
Modified: 2009-01-20 16:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-09-04 12:54:46 EDT
Description of problem:

* RHEL5.3-Server-20080904.nightly i386
* error appears through automate RHTS testing
* behavior appears arch independent

trying to install a minimal system, a traceback occurs which causes the
installer to fail:

Running anaconda, the Red Hat Enterprise Linux Server system installer - please wait...
Probing for video card:   Matrox Graphics, Inc. MGA G200e [Pilot] ServerEngines (SEP1)
Running pre-install scripts
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 954, in ?
    instClass.setInstallData(anaconda)
  File "/usr/lib/anaconda/kickstart.py", line 874, in setInstallData
    self.ksparser.readKickstart(self.file)
  File "/usr/lib/python2.4/site-packages/pykickstart/parser.py", line 1151, in readKickstart
    self.handleCommand(lineno, args)
  File "/usr/lib/anaconda/kickstart.py", line 762, in handleCommand
    self.handler.handlers[cmd](cmdArgs)
  File "/usr/lib/anaconda/kickstart.py", line 121, in doAutoPart
    if self.ksdata.encrypted:
AttributeError: KickstartData instance has no attribute 'encrypted'
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20080904.nightly

How reproducible:
always

Steps to Reproduce:
1. Try a nfs install from pxe with a ks.cfg file
  
Additional info:
This may be a indirect consequence of the bug fix for https://bugzilla.redhat.com/show_bug.cgi?id=460375
Comment 1 Chris Lumens 2008-09-04 13:19:32 EDT
Standing by with a patch for just as soon as this gets approval.
Comment 2 RHEL Product and Program Management 2008-09-04 13:36:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 David Lehman 2008-09-05 12:57:49 EDT
*** Bug 461287 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2008-09-08 11:47:36 EDT
This should be fixed in the next build of pykickstart.  Thanks for the bug report.
Comment 9 errata-xmlrpc 2009-01-20 16:02:34 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0221.html

Note You need to log in before you can comment on or make changes to this bug.