This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 461183 - Possible issue with Requires: ncurses
Possible issue with Requires: ncurses
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libpfm (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: William Cohen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 15:04 EDT by Dave Malcolm
Modified: 2013-03-11 13:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 13:39:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch to make libpfm-devel have correct dependency (1.28 KB, application/octet-stream)
2009-04-08 09:59 EDT, William Cohen
no flags Details

  None (edit)
Description Dave Malcolm 2008-09-04 15:04:29 EDT
Description of problem:
The description of libpfm-devel has this text at the end:
"Requires: ncurses"

Is this meant to be in the %description as text, or should this have been processed as package dependency metadata?

rpm -qR doesn't show a requirement on ncurses, FWIW

(FWIW, spotted by rpmlint's tag-in-description test, which has this description, which may or may not be appropriate in this case: "Something that looks like a tag was found in the package's description. This may indicate a problem where the tag was not actually parsed as a tag but just textual description content, thus being a no-op. Verify if this is the case, and move the tag to a place in the specfile where %description won't fool the specfile parser, and rebuild the package.")

Version-Release number of selected component (if applicable):
libpfm-devel-3.2-0.060926.4.el5.i386

How reproducible:
100%

Steps to Reproduce:
1. rpm -qi libpfm-devel
Comment 1 William Cohen 2009-04-08 09:59:41 EDT
Created attachment 338711 [details]
Proposed patch to make libpfm-devel have correct dependency

This patch should move the requires so it isn't assumed to be part of the description for libpfm-devel.
Comment 2 Frank Ch. Eigler 2013-03-11 13:33:51 EDT
Low priority, but trivial patch available.

Note You need to log in before you can comment on or make changes to this bug.