This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 461206 - Wrong filenames in /usr/share/sgml/docbook/xmlcatalog
Wrong filenames in /usr/share/sgml/docbook/xmlcatalog
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 17:18 EDT by Orion Poplawski
Modified: 2008-09-24 11:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: docbook-dtds-1.0-40.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 11:21:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated spec file (32.16 KB, text/plain)
2008-09-04 17:18 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2008-09-04 17:18:28 EDT
Created attachment 315811 [details]
Updated spec file

Description of problem:

The %post script that updates /usr/share/sgml/docbook/xmlcatalog has the wrong filenames for the iso*.ent entries for versions 4.4 and 4.5.  You're specifying "iso-amsa.ent" but the names are like "isoamsa.ent".

I've attached an updated spec that uses perl to parse the catalog files and uses that to update xmlcatalog.

Scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=807697

Also, looks like entries are not getting removed with the -39 version.  Haven't tested with -40.
Comment 1 Kamil Dudka 2008-09-05 05:07:09 EDT
Thank you very much for report and solution. It helps me to build libdbi-drivers-0.8.3-2.fc10 which is currently broken.

Good work.
Comment 2 Ondrej Vasik 2008-09-24 07:57:59 EDT
Thanks for report and proposed solution and sorry for long response (had some deadlines and things to finish). As opposite side I have request (bz #462997) to remove perl scripts from spec file (to remove perl requirements for docbook-dtds because of FedoraMini). From my point of view perl script is better because of decreased possibility of typos - anyway I tried your changed spec file and it doesn't work on my machine with older perl correctly - catalog registrations were completely broken. I will try to find different solution as I would like to remove the perl dependency from docbook-dtds spec file - if possible.
Comment 3 Ondrej Vasik 2008-09-24 11:21:58 EDT
Fixed package (without perl replacement) built as docbook-dtds-1.0-40.fc10 , will try to remove perl dependency from docbook-dtds somehow because of #462997 , if not possible, will use your perl scripts to prevent similar issues in future. Once more time, thanks. Closing RAWHIDE.
Following things were fixed:
- wrong filenames for xml-dtd-4.4 and xml-dtd-4.5 
  iso entities
- /ent/iso-cyr1.ent now correctly registered in xml catalog
  (there was /ent/iso-cyrl.ent typo)
- fixed broken unregistration of xml-dtds from catalog
  (missing CAT_DIR variable in %preun section)

Note You need to log in before you can comment on or make changes to this bug.