Bug 461216 - consolehelper segmentation fault
consolehelper segmentation fault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 20:53 EDT by Tom Horsley
Modified: 2008-09-05 19:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 19:36:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-09-04 20:53:48 EDT
Description of problem:

every app that is a symlink to consolehelper segfaults when I try to run
it. I first tried system-config-bind, then system-config-printer, then
system-config-user - they all die (when run as normal user or when run
as root).

Version-Release number of selected component (if applicable):
usermode-1.98-1.fc10.x86_64

How reproducible:
every time

Steps to Reproduce:
1. run any system-config-<whatever> tool
2. boom
3.
  
Actual results:
segfault

Expected results:
the config tool would be nice

Additional info:
Comment 1 Tom Horsley 2008-09-04 21:00:15 EDT
I tried a few more things, possibly something is busted in python rather
than consolehelper?

[root@zooty ~]# system-config-users 
/usr/share/system-config-users/system-config-users: line 4:  4128 Segmentation fault      /usr/bin/python2 /usr/share/system-config-users/system-config-users.py
[root@zooty ~]# yumex
/usr/share/yumex/yumex: line 5:  4133 Segmentation fault      /usr/bin/python /usr/share/yumex/yumex.pyc $*

Plain old yum still works though, so some python stuff is functional.
Comment 2 Tom Horsley 2008-09-04 21:07:00 EDT
By the way, I know yumex was functioning, because I recently downloaded
a gazillion or so updates from rawhide using it:

Sep 03 18:05:36 Updated: kernel-firmware-2.6.27-0.297.rc5.git2.fc10.noarch
Sep 03 18:06:26 Installed: kernel-2.6.27-0.297.rc5.git2.fc10.x86_64
Sep 03 18:06:48 Updated: kernel-doc-2.6.27-0.297.rc5.git2.fc10.noarch
Sep 03 18:06:50 Updated: kernel-headers-2.6.27-0.297.rc5.git2.fc10.x86_64
Sep 03 18:07:00 Installed: kernel-devel-2.6.27-0.297.rc5.git2.fc10.x86_64
Sep 03 18:07:18 Installed: kernel-2.6.27-0.297.rc5.git2.fc10.x86_64
Sep 03 18:33:29 Updated: glib2.x86_64 2.18.0-1.fc10
Sep 03 18:33:30 Updated: libxml2.x86_64 2.7.1-1.fc10
Sep 03 18:33:30 Updated: bzip2-libs.x86_64 1.0.5-3.fc10
Sep 03 18:33:32 Updated: openoffice.org-ure.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:33:32 Updated: libsoup.x86_64 2.23.91-1.fc10
Sep 03 18:33:32 Updated: hal-libs.x86_64 0.5.11-4.fc10
Sep 03 18:33:36 Updated: gnome-desktop.x86_64 2.23.91-1.fc10
Sep 03 18:33:38 Updated: gvfs.x86_64 0.99.6-1.fc10
Sep 03 18:34:02 Updated: gnome-icon-theme.noarch 2.23.91-1.fc10
Sep 03 18:34:03 Updated: openldap.x86_64 2.4.11-2.fc10
Sep 03 18:34:06 Updated: glib2-devel.x86_64 2.18.0-1.fc10
Sep 03 18:34:08 Updated: at-spi.x86_64 1.23.91-1.fc10
Sep 03 18:34:13 Updated: evolution-data-server.x86_64 2.23.91-1.fc10
Sep 03 18:34:13 Updated: nautilus-extensions.x86_64 2.23.90-4.fc10
Sep 03 18:34:15 Updated: libwnck.x86_64 2.23.91-1.fc10
Sep 03 18:34:15 Updated: audit-libs.x86_64 1.7.5-1.fc10
Sep 03 18:34:16 Updated: pciutils-libs.x86_64 3.0.0-2.fc10
Sep 03 18:34:17 Updated: pygobject2.x86_64 2.15.3-1.fc10
Sep 03 18:34:18 Updated: eel2.x86_64 2.23.91-1.fc10
Sep 03 18:34:19 Updated: rarian.x86_64 0.8.1-1.fc10
Sep 03 18:34:19 Updated: rarian-compat.x86_64 0.8.1-1.fc10
Sep 03 18:34:54 Updated: evince.x86_64 2.23.91-1.fc10
Sep 03 18:34:55 Updated: libdvdread.x86_64 4.1.3-0.3.rc1.fc10
Sep 03 18:34:56 Updated: SDL.x86_64 1.2.13-6.fc10
Sep 03 18:34:56 Updated: bzip2.x86_64 1.0.5-3.fc10
Sep 03 18:34:58 Updated: shared-mime-info.x86_64 0.51-2.fc10
Sep 03 18:34:58 Updated: gzip.x86_64 1.3.12-7.fc10
Sep 03 18:35:01 Updated: shadow-utils.x86_64 2:4.1.2-6.fc10
Sep 03 18:35:03 Updated: gnome-mag.x86_64 0.15.3-1.fc10
Sep 03 18:35:31 Updated: foomatic.x86_64 3.0.2-64.fc10
Sep 03 18:35:34 Updated: libpurple.x86_64 2.5.1-1.fc10
Sep 03 18:35:37 Updated: gtksourceview2.x86_64 2.3.2-1.fc10
Sep 03 18:35:38 Updated: gnome-menus.x86_64 2.23.91-1.fc10
Sep 03 18:35:39 Updated: libvolume_id.x86_64 127-1.fc10
Sep 03 18:35:41 Updated: udev.x86_64 127-1.fc10
Sep 03 18:35:44 Updated: hal.x86_64 0.5.11-4.fc10
Sep 03 18:35:45 Updated: wavpack.x86_64 4.50.1-2.fc10
Sep 03 18:35:45 Updated: paps-libs.x86_64 0.6.8-7.fc10
Sep 03 18:35:46 Updated: gmp.x86_64 4.2.2-8.fc10
Sep 03 18:35:55 Updated: gstreamer-plugins-good.x86_64 0.10.10-2.fc10
Sep 03 18:35:56 Updated: libxml2-python.x86_64 2.7.1-1.fc10
Sep 03 18:35:57 Updated: gtk2-engines.x86_64 2.15.4-1.fc10
Sep 03 18:35:59 Updated: binutils.x86_64 2.18.50.0.9-1.fc10
Sep 03 18:36:01 Updated: openct.x86_64 0.6.15-1.fc10
Sep 03 18:36:02 Updated: system-config-printer-libs.x86_64 1.0.7-2.fc10
Sep 03 18:36:05 Updated: dovecot.x86_64 1:1.1.3-1.fc10
Sep 03 18:36:06 Updated: libdvdnav.x86_64 4.1.3-0.4.rc1.fc10
Sep 03 18:36:29 Updated: gnome-media.x86_64 2.23.91-1.fc10
Sep 03 18:36:41 Updated: gucharmap.x86_64 2.23.91-1.fc10
Sep 03 18:36:42 Updated: pciutils.x86_64 3.0.0-2.fc10
Sep 03 18:36:44 Updated: gtkhtml3.x86_64 3.23.91-1.fc10
Sep 03 18:36:44 Updated: gvfs-fuse.x86_64 0.99.6-1.fc10
Sep 03 18:36:44 Installed: gvfs-smb.x86_64 0.99.6-1.fc10
Sep 03 18:36:44 Installed: gvfs-gphoto2.x86_64 0.99.6-1.fc10
Sep 03 18:36:44 Installed: gvfs-archive.x86_64 0.99.6-1.fc10
Sep 03 18:37:08 Updated: libgweather.x86_64 2.23.91-1.fc10
Sep 03 18:37:25 Updated: metacity.x86_64 2.23.233-1.fc10
Sep 03 18:37:27 Updated: libbtctl.x86_64 0.10.0-3.fc10
Sep 03 18:37:29 Updated: procps.x86_64 3.2.7-21.fc10
Sep 03 18:37:29 Installed: perl-Net-LibIDN.x86_64 0.10-2.fc9
Sep 03 18:37:30 Installed: libv4l.x86_64 0.4.2-1.fc10
Sep 03 18:37:31 Updated: pwlib.x86_64 1.10.10-10.fc10
Sep 03 18:37:31 Updated: sip.x86_64 4.7.7-2.fc10
Sep 03 18:37:32 Updated: libical.x86_64 0.32-1.fc10
Sep 03 18:37:33 Updated: Canna-libs.x86_64 3.7p3-25.fc10
Sep 03 18:37:35 Updated: libxml2-devel.x86_64 2.7.1-1.fc10
Sep 03 18:37:36 Updated: gnome-doc-utils-stylesheets.noarch 0.13.1-1.fc10
Sep 03 18:37:38 Updated: gnome-doc-utils.noarch 0.13.1-1.fc10
Sep 03 18:37:41 Updated: at-spi-python.x86_64 1.23.91-1.fc10
Sep 03 18:37:42 Updated: bzip2-devel.x86_64 1.0.5-3.fc10
Sep 03 18:38:09 Updated: oxygen-icon-theme.noarch 4.1.1-2.fc10
Sep 03 18:38:10 Updated: kdelibs-common.x86_64 6:4.1.1-3.fc10
Sep 03 18:38:29 Updated: kdelibs.x86_64 6:4.1.1-3.fc10
Sep 03 18:38:34 Updated: kdepimlibs.x86_64 4.1.1-1.fc10
Sep 03 18:38:42 Updated: kdelibs-devel.x86_64 6:4.1.1-3.fc10
Sep 03 18:38:59 Updated: kdebase-runtime.x86_64 4.1.1-2.fc10
Sep 03 18:38:59 Updated: ksysguardd.x86_64 4.1.1-2.fc10
Sep 03 18:39:02 Updated: PyKDE4.x86_64 4.1.1-1.fc10
Sep 03 18:39:08 Updated: orca.x86_64 2.23.91-1.fc10
Sep 03 18:39:17 Updated: yelp.x86_64 2.23.91-1.fc10
Sep 03 18:39:38 Updated: nautilus.x86_64 2.23.90-4.fc10
Sep 03 18:39:47 Updated: cheese.x86_64 2.23.91-1.fc10
Sep 03 18:39:47 Updated: paps.x86_64 0.6.8-7.fc10
Sep 03 18:39:47 Updated: xorg-x11-drv-synaptics.x86_64 0.15.0-4.fc10
Sep 03 18:40:07 Updated: gnome-power-manager.x86_64 2.23.91-1.fc10
Sep 03 18:40:27 Updated: gedit.x86_64 1:2.23.91-1.fc10
Sep 03 18:40:43 Updated: pidgin.x86_64 2.5.1-1.fc10
Sep 03 18:40:46 Updated: lsdvd.x86_64 0.16-10.fc10
Sep 03 18:40:46 Updated: evince-djvu.x86_64 2.23.91-1.fc10
Sep 03 18:40:46 Updated: evince-dvi.x86_64 2.23.91-1.fc10
Sep 03 18:41:04 Updated: eog.x86_64 2.23.91-1.fc10
Sep 03 18:41:14 Updated: file-roller.x86_64 2.23.91-1.fc10
Sep 03 18:41:32 Updated: gnome-terminal.x86_64 2.23.91-1.fc10
Sep 03 18:41:48 Updated: gconf-editor.x86_64 2.23.91-1.fc10
Sep 03 18:42:02 Updated: gnome-system-monitor.x86_64 2.23.91-1.fc10
Sep 03 18:42:13 Updated: gcalctool.x86_64 5.23.91-1.fc10
Sep 03 18:42:32 Updated: gok.x86_64 2.23.91-1.fc10
Sep 03 18:42:32 Updated: audit-libs-python.x86_64 1.7.5-1.fc10
Sep 03 18:42:33 Updated: audit.x86_64 1.7.5-1.fc10
Sep 03 18:42:33 Updated: openldap-clients.x86_64 2.4.11-2.fc10
Sep 03 18:42:34 Updated: gvfs-obexftp.x86_64 0.99.6-1.fc10
Sep 03 18:42:49 Updated: gnome-settings-daemon.x86_64 2.23.91-1.fc10
Sep 03 18:42:51 Updated: elinks.x86_64 0.12-0.4.pre1.fc10
Sep 03 18:43:05 Updated: vino.x86_64 2.23.91-1.fc10
Sep 03 18:43:18 Updated: gnome-session.x86_64 2.23.91-1.fc10
Sep 03 18:43:23 Updated: fvwm.x86_64 2.5.26-2.fc10
Sep 03 18:43:23 Updated: tree.x86_64 1.5.2.1-1.fc10
Sep 03 18:43:24 Updated: mtr.x86_64 2:0.73-2.fc10
Sep 03 18:43:27 Updated: rsyslog.x86_64 3.21.3-3.fc10
Sep 03 18:43:27 Updated: xorg-x11-drv-nouveau.x86_64 1:0.0.11-1.20080902git6dd8ad4.fc10
Sep 03 18:43:27 Updated: pygobject2-doc.x86_64 2.15.3-1.fc10
Sep 03 18:43:28 Updated: pygobject2-codegen.x86_64 2.15.3-1.fc10
Sep 03 18:43:28 Updated: pygobject2-devel.x86_64 2.15.3-1.fc10
Sep 03 18:43:31 Updated: kdepimlibs-devel.x86_64 4.1.1-1.fc10
Sep 03 18:43:31 Updated: gnome-desktop-devel.x86_64 2.23.91-1.fc10
Sep 03 18:43:32 Updated: libsoup-devel.x86_64 2.23.91-1.fc10
Sep 03 18:43:32 Updated: eel2-devel.x86_64 2.23.91-1.fc10
Sep 03 18:43:32 Updated: sip-devel.x86_64 4.7.7-2.fc10
Sep 03 18:43:33 Updated: perl-IO-Socket-SSL.noarch 1.15-1.fc10
Sep 03 18:43:33 Updated: pciutils-devel.x86_64 3.0.0-2.fc10
Sep 03 18:43:35 Updated: system-config-printer.x86_64 1.0.7-2.fc10
Sep 03 18:43:52 Updated: gnome-themes.noarch 2.23.91-1.fc10
Sep 03 18:43:52 Updated: gmp-devel.x86_64 4.2.2-8.fc10
Sep 03 18:43:52 Updated: hal-devel.x86_64 0.5.11-4.fc10
Sep 03 18:43:56 Updated: SDL-devel.x86_64 1.2.13-6.fc10
Sep 03 18:43:57 Updated: at-spi-devel.x86_64 1.23.91-1.fc10
Sep 03 18:44:00 Updated: openldap-devel.x86_64 2.4.11-2.fc10
Sep 03 18:44:03 Updated: gnome-backgrounds.noarch 2.23.91-1.fc10
Sep 03 18:44:05 Updated: binutils-devel.x86_64 2.18.50.0.9-1.fc10
Sep 03 18:44:05 Updated: fedora-bookmarks.noarch 10-1
Sep 03 18:44:08 Updated: glib2.i386 2.18.0-1.fc10
Sep 03 18:44:53 Updated: openoffice.org-core.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:44:54 Updated: rpm-libs.x86_64 4.5.90-0.git8461.4
Sep 03 18:45:00 Updated: mono-core.x86_64 2.0-5.fc10
Sep 03 18:45:16 Updated: kdebase-workspace.x86_64 4.1.1-2.fc10
Sep 03 18:45:21 Updated: rpm.x86_64 4.5.90-0.git8461.4
Sep 03 18:45:23 Updated: openoffice.org-brand.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:45:25 Updated: kdebase-workspace-libs.x86_64 4.1.1-2.fc10
Sep 03 18:45:28 Updated: openoffice.org-calc-core.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:45:30 Installed: kdevelop-libs.x86_64 9:3.5.3-1.fc10
Sep 03 18:45:32 Updated: openoffice.org-base-core.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:45:33 Updated: gdb.x86_64 6.8-24.fc10
Sep 03 18:45:37 Updated: openoffice.org-impress-core.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:45:48 Updated: openoffice.org-presenter-screen.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:04 Updated: kdeaccessibility.x86_64 1:4.1.1-1.fc10
Sep 03 18:46:05 Updated: openoffice.org-math-core.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:08 Updated: openoffice.org-writer-core.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:09 Updated: openoffice.org-graphicfilter.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:27 Updated: kdevelop.x86_64 9:3.5.3-1.fc10
Sep 03 18:46:27 Updated: openoffice.org-writer.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:28 Updated: openoffice.org-impress.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:42 Updated: bug-buddy.x86_64 1:2.23.91.1-1.fc10
Sep 03 18:46:43 Updated: openoffice.org-calc.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:44 Updated: kdebase-workspace-devel.x86_64 4.1.1-2.fc10
Sep 03 18:46:45 Updated: rpm-devel.x86_64 4.5.90-0.git8461.4
Sep 03 18:46:45 Updated: rpm-build.x86_64 4.5.90-0.git8461.4
Sep 03 18:46:47 Updated: man.x86_64 1.6f-9.fc10
Sep 03 18:46:48 Updated: rpm-python.x86_64 4.5.90-0.git8461.4
Sep 03 18:46:50 Updated: kdeartwork.x86_64 4.1.1-1.fc10
Sep 03 18:46:51 Updated: mono-data.x86_64 2.0-5.fc10
Sep 03 18:46:52 Updated: mono-data-sqlite.x86_64 2.0-5.fc10
Sep 03 18:46:52 Updated: openoffice.org-draw-core.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:58 Updated: openoffice.org-pdfimport.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:58 Updated: openoffice.org-draw.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:58 Updated: openoffice.org-math.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:59 Updated: openoffice.org-xsltfilter.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:46:59 Updated: openoffice.org-langpack-en.x86_64 1:3.0.0-4.1.fc10
Sep 03 18:47:00 Updated: mono-winforms.x86_64 2.0-5.fc10
Sep 03 18:47:01 Updated: mono-extras.x86_64 2.0-5.fc10
Sep 03 18:47:03 Updated: mono-web.x86_64 2.0-5.fc10
Sep 03 18:50:19 Updated: rpm.x86_64 4.5.90-0.git8461.4

One of those musta busted things (if only I knew which one :-).
Comment 3 Miloslav Trmač 2008-09-05 05:03:38 EDT
Thanks for your report.

> [root@zooty ~]# system-config-users 
> /usr/share/system-config-users/system-config-users: line 4:  4128 Segmentation
fault
> /usr/bin/python2 /usr/share/system-config-users/system-config-users.py

This indicates the problem is not in consolehelper because consolehelper has already executed the application as root.

Reassigning to Python as a guess.

In order to help debugging the problem, please run "/usr/bin/python2 /usr/share/system-config-users/system-config-users.py" as root (without consolehelper).  If it still crashes, please obtain a backtrace (see http://fedoraproject.org/wiki/StackTraces ) and attach it to this bug report.
Comment 4 Tom Horsley 2008-09-05 19:36:03 EDT
I was gonna get the backtraces, but I first downloaded the latest updates
(which included new versions of several of the packages listed above), and
everything seems to be working now, so I guess whatever was busted is
fixed in the latest rawhide. I'm attempting to close this (I'll see if
it works :-).

Note You need to log in before you can comment on or make changes to this bug.