Bug 461269 - nspluginwrapper needs to be built against latest gecko-libs
nspluginwrapper needs to be built against latest gecko-libs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nspluginwrapper (Show other bugs)
5.3
All Linux
medium Severity high
: beta
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 09:23 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.91.5-22.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 08:15:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2008-09-05 09:23:24 EDT
Description of problem:
xulrunner has been updated to provide gecko-libs=1.9.0.2 so nspluginwrapper needs to be rebuilt against the latest libraries.  I'm seeing dependency issues with the RHEL5.3-*-20080905.nightly trees.
Comment 1 Martin Stransky 2008-09-05 09:59:37 EDT
This gecko-libs dependency was fixed in nspluginwrapper-0.9.91.5-22.el5 (RHSA-2008:0597-09)
Comment 2 Jay Turner 2008-09-05 13:06:08 EDT
No, appears that's not the case.

$ rpm -qpR nspluginwrapper-0.9.91.5-22.el5.x86_64.rpm | grep gecko
gecko-libs >= 1.9
Comment 3 Martin Stransky 2008-09-05 16:37:25 EDT
Am I missing something? Because the condition gecko-libs >= 1.9 should fit (and it fits on my box) the gecko-libs = 1.9.0.2...
Comment 4 Jay Turner 2008-09-08 07:01:30 EDT
Sorry, I'm stupid and can't read.  Indeed ">= 1.9" should satisfy things.  I'll confirm today and close out this issue.

Please ensure 0.9.91.5-22.el5 is tagged appropriately so it is pulled into the nightly composes.  -21.el5 is still getting pulled in currently.
Comment 5 Jay Turner 2008-09-08 10:18:06 EDT
Fix confirmed with 0.9.91.5-22.el5 so just needs to be tagged appropriately in order to get picked up in 5.3-candidate builds.
Comment 6 Jay Turner 2008-09-23 08:15:24 EDT
The package is part of the beta-candidate builds (20080919.1 for Server and 20080919.2 for Client)

Note You need to log in before you can comment on or make changes to this bug.