Bug 461301 - cman package should depend on pexpect
cman package should depend on pexpect
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 13:45 EDT by Nate Straz
Modified: 2009-04-16 18:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:51:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2008-09-05 13:45:07 EDT
Description of problem:

pexpect is a python module which 6 fence agents now use.  This is a change from the RHEL5.2 version of cman.  Without the dependency upgrades will not pull in the new requirement for fence agents for apc, bladecenter, drac5, ilo, lpar, and wti.  Since this is a library with no other dependencies it should be required by cman.


Version-Release number of selected component (if applicable):
cman-2.0.87-5.el5
Comment 1 Chris Feist 2008-09-05 14:55:48 EDT
Since virtually all the new fence agents require pexpect I think the right choice is to require it with cman.

I've added this to the .spec file and it should be in cman after 2.0.87-5.el5.
Comment 3 Chris Feist 2008-09-08 12:02:38 EDT
Built in latest cman.

cman-2.0.88-2.el5
Comment 6 errata-xmlrpc 2009-01-20 16:51:08 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0189.html

Note You need to log in before you can comment on or make changes to this bug.