Bug 461317 - Own /usr/share/augeas/lenses
Own /usr/share/augeas/lenses
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 637854
  Show dependency treegraph
 
Reported: 2008-09-05 15:06 EDT by David Lutterkort
Modified: 2015-03-04 20:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 637854 (view as bug list)
Environment:
Last Closed: 2008-09-06 05:57:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lutterkort 2008-09-05 15:06:59 EDT
The directory /usr/share/augeas/lenses contains lenses (text files) that Augeas (http://augeas.net/) uses to parse and process configuration files.

This directory is currently owned by the augeas-libs RPM; since there are other packages (e.g. libvirt) that are interested in shipping lenses, that's not a good situation: installing Augeas should be a decision up to the user, and it is explicitly designed so that other packages can ship lens definitions without requiring Augeas itself - they only drop a text file into /usr/share/augeas/lenses to make themselves manageable by Augeas

Hence %{_datadir}/lenses needs to be owned by a neutral third party, i.e. filesystem.
Comment 1 David Lutterkort 2008-09-05 15:08:04 EDT
That should be %{_datadir}/augeas/lenses
Comment 2 Phil Knirsch 2008-09-06 05:57:12 EDT
Added in filesystem-2.4.19-1.fc10.

Thanks,

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.