Bug 461367 - firstboot traceback: 'NoneType' object has no attribute 'beenset'
firstboot traceback: 'NoneType' object has no attribute 'beenset'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 453225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-06 13:49 EDT by Axel Thimm
Modified: 2008-10-27 05:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 05:44:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2008-09-06 13:49:02 EDT
Description of problem:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/interface.py", line 274, in createScreens
    module.createScreen()
  File "/usr/share/firstboot/modules/keyboard.py", line 148, in createScreen
    if not self.kbd.beenset:
AttributeError: 'NoneType' object has no attribute 'beenset'


Version-Release number of selected component (if applicable):
firstboot-1.97-1.fc9.i386

How reproducible:
100%

Steps to Reproduce:
1.Install Fedora 9 with updates repo enabled
2.
3.
  
Actual results:
See above

Expected results:
The usual firstboot experience

Additional info:
Comment 1 Lubomir Rintel 2008-10-27 05:10:57 EDT
*** Bug 453225 has been marked as a duplicate of this bug. ***
Comment 2 Lubomir Rintel 2008-10-27 05:44:07 EDT
I think Chris Lumens fixed this.

Note You need to log in before you can comment on or make changes to this bug.