Bug 461382 - kdebase-workspace update breaks dependencies
kdebase-workspace update breaks dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-06 22:52 EDT by Michal Jaegermann
Modified: 2008-09-07 10:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-07 10:46:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-09-06 22:52:03 EDT
Description of problem:

kdebase-workspace-libs-4.1.0-8.fc9 provides libplasma.so.2,
as needed by kdeplasma-addons-4.1.0-1.fc9.  The trouble
is that extragear-plasma-4.0.1-5.fc9, present in an installation
set, requires libplasma.so.1.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.1.0-8.fc9
Comment 1 Rex Dieter 2008-09-07 05:31:08 EDT
kdeaddons-plasma Obsoletes/Provides extragear-plasma, and is properly linked against the new(er) libplasma.so.2
Comment 2 Michal Jaegermann 2008-09-07 10:46:17 EDT
You mean kdeplasma-addons-4.1.0-1.fc9, I guess.
'repoclosure' utility somehow managed to miss that
without any apparent reason.  My mistake.
Comment 3 Kevin Kofler 2008-09-07 10:51:29 EDT
repoclosure doesn't really understand Obsoletes. This is a false positive.

Note You need to log in before you can comment on or make changes to this bug.