Bug 461409 - host(1) is unable to handle IDN domains on non-UTF8 terminals
host(1) is unable to handle IDN domains on non-UTF8 terminals
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-07 07:55 EDT by Robert Scheck
Modified: 2013-04-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 04:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-09-07 07:55:07 EDT
Description of problem:
host(1) is unable to handle IDN domains on non-UTF8 terminals, see below:

$ echo $LANG
de_DE@euro
$

$ host dänic.de
dänic.de has address 81.90.194.14
Host dänic.de not found: 3(NXDOMAIN)
Host dänic.de not found: 3(NXDOMAIN)
$

As it seems, the recoding from UTF-8 -> ISO-8859-1 is missing somewhere
which also causes the NXDOMAIN errors then. Once the character "ä" gets
"ä", it's UTF-8 on a non-UTF8 terminal, so the recoding is broken - as
far as I can remember, this ever was case since IDN support in host(1)
is enabled now. Can we please get rid of this before F10? :)

Version-Release number of selected component (if applicable):
bind-utils-9.5.1-0.5.b1

How reproducible:
Everytime, see above.

Actual results:
host(1) is unable to handle IDN domains on non-UTF8 terminals.

Expected results:
Working handling of IDN domains on UTF-8 and non-UTF8 terminals.
Comment 1 Adam Tkac 2008-09-16 08:33:30 EDT
Could you please test if http://kojiweb.fedoraproject.org/koji/taskinfo?taskID=827912 works as expected? Thanks
Comment 2 Robert Scheck 2008-09-16 15:00:39 EDT
Yes, now it works for me as expected:

$ echo $LANG
de_DE@euro
$

$ host dänic.de
dänic.de has address 81.90.194.14
$

Can we please get this fix into Fedora and also into upstream?
Comment 3 Adam Tkac 2008-09-17 03:39:00 EDT
(In reply to comment #2)
> Yes, now it works for me as expected:

Thanks for feedback
Comment 4 Adam Tkac 2008-09-17 04:05:32 EDT
fixed in bind-9.5.1-0.6.b1.fc10

Note You need to log in before you can comment on or make changes to this bug.