Bug 461433 - CodecBuddy notice invites you to install proprietary codecs when you play some Ogg files
CodecBuddy notice invites you to install proprietary codecs when you play som...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: codeina (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-07 18:41 EDT by Gregory Maxwell
Modified: 2008-09-07 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-07 19:40:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Maxwell 2008-09-07 18:41:38 EDT
Description of problem:

The CodecBuddy support brings up the proprietary codec notice in all cases when it encounters a codec that it can't play.

Ogg/Skeleton streams (http://wiki.xiph.org/OggSkeleton) are produced by modern Ogg/Theora encoders. The gstreamer shipped with Fedora doesn't know what to do with Skeleton (nor does it really need to) so the user gets the confusing invitation to install proprietary codecs and the admonishment to use free formats when they ARE using a free format. 

Subtitles (Ogg/Kate http://wiki.xiph.org/index.php/OggKate) also trigger this behavior. 

Version-Release number of selected component (if applicable):
Whatever is shipping in F9

How reproducible:

Steps to Reproduce:
1. Take a fresh F9 system which hasn't been told not to display the codec warning anymore.
2. Visit http://ubuntu.media.mit.edu/gnu/ and view the videos 
  
Actual results:
Confusing and misleading warning.

Expected results:
Video plays without protest (because the file is Ogg/ and non-free formats are very rare in Ogg, or because the software has a blacklist of non-free formats)
Comment 1 Bastien Nocera 2008-09-07 19:40:44 EDT
The first one is already fixed in GStreamer in rawhide, we need to backport the patch to F-9 (bug #458404).

The second one is also a bug in GStreamer, or the fact that the video is busted. See http://bugzilla.gnome.org/show_bug.cgi?id=550582

Note You need to log in before you can comment on or make changes to this bug.