Bug 461459 - White screen on login to compiz-managed session
White screen on login to compiz-managed session
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-08 04:34 EDT by Matěj Cepl
Modified: 2018-04-11 12:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:09:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core dump (652.57 KB, application/octet-stream)
2008-09-08 04:34 EDT, Matěj Cepl
no flags Details
backtrace from the core file (493 bytes, text/plain)
2008-09-08 04:36 EDT, Matěj Cepl
no flags Details
/etc/X11/xorg.conf (774 bytes, text/plain)
2008-09-08 04:36 EDT, Matěj Cepl
no flags Details
/var/log/Xorg.0.log (73.43 KB, text/plain)
2008-09-08 04:36 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-09-08 04:34:52 EDT
Created attachment 316053 [details]
core dump

Description of problem:
After login to the session with desktop-effects on, I get only white screen all over whole screen. When blindly typing desktop-effects and pressing space, I get perfectly working Gnome (actually, the very session I am in just now).

Version-Release number of selected component (if applicable):
this is what I've got from debuginfo-install:
compiz-debuginfo-0.7.6-3.fc9.1.i386
dbus-debuginfo-1.2.1-2.fc9.i386
fuse-debuginfo-2.7.3-3.fc9.i386
glibc-debuginfo-2.8-8.i686
libICE-debuginfo-1.0.4-3.fc9.i386
libSM-debuginfo-1.1.0-1.fc9.i386
libxcb-debuginfo-1.1-4.fc9.i386
libXcomposite-debuginfo-0.4.0-4.fc9.i386
libXdamage-debuginfo-1.1.1-4.fc9.i386
libXext-debuginfo-1.0.4-1.fc9.i386
libXfixes-debuginfo-4.0.3-3.fc9.i386
libXinerama-debuginfo-1.0.3-1.fc9.i386
libxml2-debuginfo-2.7.1-1.fc9.i386
libXrandr-debuginfo-1.2.2-3.fc9.i386
libXrender-debuginfo-0.9.4-3.fc9.i386
libxslt-debuginfo-1.1.24-2.fc9.i386
libX11-debuginfo-1.1.4-1.fc9.i386
mesa-debuginfo-7.1-0.37.fc9.i386
startup-notification-debuginfo-0.9-4.fc9.i386
zlib-debuginfo-1.2.3-18.fc9.i386
2:libpng-debuginfo-1.2.29-1.fc9.i386

How reproducible:
100% (tried two times, plus it happened to me last time I tried copmiz)

Steps to Reproduce:
1.enable desktop-effects
2.logout (or reboot)
3.login
  
Actual results:
white screen

Expected results:
no white screen

Additional info:
I have also found a nice core dump, so I am adding some analysis of that.
Comment 1 Matěj Cepl 2008-09-08 04:36:15 EDT
Created attachment 316054 [details]
backtrace from the core file
Comment 2 Matěj Cepl 2008-09-08 04:36:35 EDT
Created attachment 316055 [details]
/etc/X11/xorg.conf
Comment 3 Matěj Cepl 2008-09-08 04:36:58 EDT
Created attachment 316056 [details]
/var/log/Xorg.0.log
Comment 4 Matěj Cepl 2008-09-08 04:37:20 EDT
Comment on attachment 316054 [details]
backtrace from the core file

Quite unsatisfactory, I know.
Comment 5 Matěj Cepl 2008-09-08 04:39:13 EDT
Wondering if it has anything to do with bug 254098
Comment 6 Jesse Brandeburg 2008-09-27 14:24:07 EDT
I see the same thing running rawhide modesetting kernel, 2.6.27-0.352.rc7.git1.fc10.i686

I'm running mostly F9 bits but am about to do a rawhide full upgrade.

I have an IBM/Lenovo T43 laptop with radeon graphics model 2668-nu3

desktop effects mostly worked before the modesetting kernel upgrade with yum (from rawhide)
Comment 7 Warren Togami 2008-11-27 14:09:49 EST
compiz does this whenever you try to run it on a system not capable of composite.  Ubuntu's compiz has extremely ugly non-upstream wrappers to detect and fallback from this condition.
Comment 8 Gabriel Somlo 2009-01-01 20:31:13 EST
re: comment #7: mcepl's Xorg.0.log contains the following:

(II) EXA(0): Driver registered support for the following operations:
(II)         Solid
(II)         Copy
(II)         Composite (RENDER acceleration)

Does this not mean his system *is* capable of composite ? Otherwise, what command would one need to execute to unequivocally answer that question ?

I'm getting the same behavior on Fedora 10, on both a ppc PowerBook with a radeon card
(0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10])
which similarly seems to support composite:

(II) EXA(0): Driver registered support for the following operations:
(II)         Solid
(II)         Copy
(II)         Composite (RENDER acceleration)
(II)         UploadToScreen
(II)         DownloadFromScreen
(II) RADEON(0): Acceleration enabled

I'm also getting the exact same behavior on a Santa Rosa macbook pro with an nvidia card
(01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600M GT (rev a1))
which does not seem to support composite, if the Xorg.0.log is to be believed (using the nv driver).

On both machines, compiz turns the screen white, the cursor changes shape depending over which (invisible) window it hovers, and if I move the mouse to the upper-right corner I see the expose-like behavior happening, but windows are empty except for an icon in one of the lower corners. Clicking on one window moves them back in place, and they all turn completely white again.

I find it confusing that the presence or absence of Composite support doesn't seem to make a difference.
Comment 9 Bug Zapper 2009-06-09 22:39:35 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-07-14 13:09:49 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.