Bug 461485 - RHTS installs crashing with "error: no dbpath has been set"
RHTS installs crashing with "error: no dbpath has been set"
Status: CLOSED DUPLICATE of bug 460375
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-08 10:16 EDT by Prarit Bhargava
Modified: 2008-09-08 10:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 10:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2008-09-08 10:16:27 EDT
* I'm not 100% convinced this is an anaconda issue or if this is a RHTS issue.  For now, I'm putting this in anaconda *

Description of problem:

RHTS installs seem to be failing with:

Retrieving installation information...
In progress...    Completed Completed
Retrieving installation information...
In progress...    Completed Completed
Retrieving installation information...
In progress...    Completed Completed
error: no dbpath has been set
error: cannot open Packages database in /mnt/sysimage/%{_dbpath}
Traceback (most recent call first):
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 206, in _all_packages
    mi = ts.dbMatch()
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 235, in _make_header_dict
    for (hdr, idx) in self._all_packages():
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 59, in _get_pkglist
    self._make_header_dict()
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 158, in simplePkgList
    return self.pkglist
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 528, in _getGroups
    pkglist = self.rpmdb.simplePkgList()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 470, in doGroupSetup
    return self._getGroups()
  File "/usr/lib/anaconda/yuminstall.py", line 856, in doGroupSetup
    self.ayum.doGroupSetup()
  File "/usr/lib/anaconda/yuminstall.py", line 945, in doRepoSetup
    self.doGroupSetup()
  File "/usr/lib/anaconda/backend.py", line 172, in doRepoSetup
    anaconda.backend.doRepoSetup(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 223, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/cmdline.py", line 124, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/bin/anaconda", line 982, in ?
    anaconda.intf.run(anaconda)
TypeError: rpmdb open failed

install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system

Version-Release number of selected component (if applicable): latest RHEL5 trees as far back as 20080827


How reproducible: 100% (AFAICT)


Steps to Reproduce:
1. Reserve system in RHTS (via web or command line)
2.
3.
  
Actual results: See above output.

Expected results: Install should succeed


Additional info:  Seen on hp-dl380g5-01.rhts.bos.redhat.com, but IIRC I've seen this on several other systems.
Comment 1 Chris Lumens 2008-09-08 10:23:40 EDT

*** This bug has been marked as a duplicate of bug 460375 ***

Note You need to log in before you can comment on or make changes to this bug.