Bug 46165 - rpm installation fails to run mysql_install_db
rpm installation fails to run mysql_install_db
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-27 02:17 EDT by George Loyer
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 00:30:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Loyer 2001-06-27 02:17:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
The original installation (upgrade) of mysql from the 7.1 dist disk fails,
and a subsequent rpm -e and rpm -ivh of the mysql-* files from disk 2 fail
to run mysql_install_db. This results in failure of safe_mysqld & failing
because there is no mysql database in the home directory (/var/lib/mysql).

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh all of the mysql-* files on disk 2 of the 7.1 workstation
release. don't forget the perl-DBD-MySQL* rpm
2. 
3.
	

Actual Results:  the rpm -ivh of mysql-3.23... should have run
mysql_install_db. It doesn't, so you don't get the "you just installed
mysql and here's what you do next" text message (about a page). Trying to
start the server with safe_mysqld & fails because there is no mysql
database at /var/lib/mysql

Expected Results:  mysql_install_db should be run and create the mysql
database, allowing the server startup.

Additional info:

I worked around this by running mysql_install_db manually, but that had a
subsequent failure. I ran it as root and it created the mysql database and
the test database owned by root and in the root group. This caused
safe_mysqld & to fail (noted in the /var/log/ error log) because it
"couldn't find host.frm", one of the tables in mysql. Once I changed owner
and group of all database files to mysql, it started normally.
Comment 1 Trond Eivind Glomsrxd 2001-06-27 08:53:21 EDT
You shouldn't run mysql_install_db at all - or safe_mysqld, for that matter. Use
"service mysqld start", which automatically will initialize the database on the
first run.
Comment 2 George Loyer 2001-06-28 00:30:16 EDT
The "not a bug" response from teg addresses the problem caused by attempting to
start the system with mysql_install_db and safe_mysqld (BTW, where is the
'service mysql start' solution documented??). That was an attempted workaround
for the rpm installation failure.

It does NOT address the problem that all of this is supposed to be run during
the RPM installation of the mysql-3.23...rpm file, which I (great leap here)
assume operates like the latest version from mysql.com.
Comment 3 Trond Eivind Glomsrxd 2001-06-28 10:35:17 EDT
No, they are different from the ones on mysql.com - and they don't run this
during rpm install because it is run automatically the first time you start
mysql ("service mysqld start")

Note You need to log in before you can comment on or make changes to this bug.