Bug 461665 - xulrunner fails to download a file to the totem plugin
xulrunner fails to download a file to the totem plugin
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 15:23 EDT by Kjartan Maraas
Modified: 2009-04-02 08:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 08:11:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzipped logfile (161.76 KB, application/x-compressed-tar)
2008-09-19 13:39 EDT, Kjartan Maraas
no flags Details
log of HTTP debugging (2.23 MB, text/plain)
2008-09-22 10:38 EDT, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 486346 None None None Never

  None (edit)
Description Kjartan Maraas 2008-09-09 15:23:35 EDT
Description of problem:

I filed this bug:
http://bugzilla.gnome.org/show_bug.cgi?id=551532

and was told by Bastien to file a bug against xulrunner because wget can fetch the file just fine.

The url is:
'http://webtv.tv2.no/webtv/metafile.asx?MSG=WFdB4dWhmEFZyHntO1yAM5W2boPwDw8)hy8r5XZBDr8qB6JiO(EkVasdwqqZR55dVZq1ohoDDT61ZnPhMAffo9z6nrHFERALVPWQG6kE(iE5AfRFCxvMJo2jI9Yvzknr'

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2008-09-19 12:24:32 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Then, if could provide us with some debugging information about what firefox is trying to do -- visit http://www.mozilla.org/projects/netlib/http/http-debugging.html to get more information how to do it.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Kjartan Maraas 2008-09-19 13:24:00 EDT
alsa-plugins-oss-1.0.18-1.rc3.fc10.i386
alsa-plugins-pulseaudio-1.0.18-1.rc3.fc10.i386
firefox-3.0.1-1.fc10.i386
firefox-debuginfo-3.0.1-1.fc10.i386
flash-plugin-10.0.1.218-release.i386
gnumeric-plugins-extras-1.8.2-2.fc9.i386
gstreamer-plugins-bad-0.10.8-1.lvn10.i386
gstreamer-plugins-bad-debuginfo-0.10.8-1.lvn10.i386
gstreamer-plugins-bad-devel-0.10.8-1.lvn10.i386
gstreamer-plugins-bad-extras-0.10.8-1.lvn10.i386
gstreamer-plugins-base-0.10.20-4.fc10.i386
gstreamer-plugins-base-debuginfo-0.10.20-4.fc10.i386
gstreamer-plugins-base-devel-0.10.20-4.fc10.i386
gstreamer-plugins-farsight-0.12.9-1.fc10.i386
gstreamer-plugins-farsight-debuginfo-0.12.9-1.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
gstreamer-plugins-flumpegdemux-debuginfo-0.10.15-4.fc10.i386
gstreamer-plugins-good-0.10.10-4.fc10.i386
gstreamer-plugins-good-debuginfo-0.10.10-4.fc10.i386
gstreamer-plugins-good-devel-0.10.10-4.fc10.i386
gstreamer-plugins-pulse-0.9.7-1.fc10.i386
gstreamer-plugins-pulse-debuginfo-0.9.7-1.fc10.i386
gstreamer-plugins-schroedinger-1.0.5-2.fc10.i386
gstreamer-plugins-ugly-0.10.8-1.lvn10.i386
gstreamer-plugins-ugly-debuginfo-0.10.8-1.lvn10.i386
gutenprint-plugin-5.0.2-3.fc10.i386
java-1.6.0-openjdk-plugin-1.6.0.0-0.20.b11.fc10.i386
maven2-plugin-release-2.0.4-10.15.fc10.i386
maven-shared-plugin-testing-harness-1.0-4.6.fc10.i386
mozilla-filesystem-1.9-2.fc10.i386
nspluginwrapper-1.1.0-6.fc10.i386
PackageKit-browser-plugin-0.3.3-2.fc10.i386
plymouth-plugin-fade-in-0.6.0-0.2008.09.10.1.fc10.i386
plymouth-plugin-label-0.6.0-0.2008.09.10.1.fc10.i386
plymouth-plugin-spinfinity-0.6.0-0.2008.09.10.1.fc10.i386
seahorse-plugins-2.23.92-1.fc10.i386
seahorse-plugins-debuginfo-2.23.92-1.fc10.i386
setroubleshoot-plugins-2.0.8-1.fc10.noarch
totem-mozplugin-2.23.91-3.fc10.i386
xulrunner-1.9.0.1-2.fc10.i386
xulrunner-debuginfo-1.9.0.1-2.fc10.i386
xulrunner-devel-1.9.0.1-2.fc10.i386
xulrunner-devel-unstable-1.9.0.1-2.fc10.i386
Comment 3 Kjartan Maraas 2008-09-19 13:38:46 EDT
There's some more information in the upstream bug here:
http://bugzilla.gnome.org/show_bug.cgi?id=551532

I'll attach the log file from my http debugging session too.
Comment 4 Kjartan Maraas 2008-09-19 13:39:43 EDT
Created attachment 317218 [details]
gzipped logfile
Comment 5 Matěj Cepl 2008-09-22 10:38:05 EDT
Created attachment 317366 [details]
log of HTTP debugging
Comment 6 Matěj Cepl 2008-09-22 10:38:59 EDT
Comment on attachment 317366 [details]
log of HTTP debugging

silly me, bad description
Comment 7 Martin Stransky 2008-10-29 08:28:53 EDT
The provided URL doesn't seen to be valid - I got (by wget):

<ASX VERSION="3.0">
<TITLE>Ingen tilgang til å spille av denne videoen.</TITLE>
        <ENTRY>
                <TITLE>Videoen er ikke tilgjengelig.</TITLE>
                <ABSTRACT>Ingen tilgang til å spille av denne videoen.</ABSTRACT>
                <PARAM NAME="entry-type" VALUE="error"/>
                <REF HREF="http://webtv.tv2.no/webtv/sumo/images/metafileFailure.jpg" />
                <DURATION VALUE="00:00:20"/>
        </ENTRY>
</ASX>
Comment 8 Martin Stransky 2008-10-29 08:29:23 EDT
Can you provide any other (working) url?
Comment 9 Kjartan Maraas 2008-11-05 07:24:10 EST
This one looks like it's doing the same:

http://webtv.tv2.no/webtv/metafile.asx?MSG=Uu65vkApR)RAoBHUHV4hGU5IIdHyPHjXKs2(RDwvXOi)DY(h6TAEWNrcrAUqHREutUNADsdwOfnkRKoJ)ZnUDbDMjTyGx0kwHk43jyHNN4E!


From livehttpheaders:

http://webtv.tv2.no/webtv/metafile.asx?MSG=Uu65vkApR)RAoBHUHV4hGU5IIdHyPHjXKs2(RDwvXOi)DY(h6TAEWNrcrAUqHREutUNADsdwOfnkRKoJ)ZnUDbDMjTyGx0kwHk43jyHNN4E!



GET /webtv/metafile.asx?MSG=Uu65vkApR)RAoBHUHV4hGU5IIdHyPHjXKs2(RDwvXOi)DY(h6TAEWNrcrAUqHREutUNADsdwOfnkRKoJ)ZnUDbDMjTyGx0kwHk43jyHNN4E! HTTP/1.1

Host: webtv.tv2.no

User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.9.0.2) Gecko/2008102718 Fedora/3.0.2-1.fc10 Firefox/3.0.2

Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

Accept-Language: nb,en-us;q=0.7,en;q=0.3

Accept-Encoding: gzip,deflate

Accept-Charset: UTF-8,*

Keep-Alive: 300

Connection: keep-alive

Cookie: RMID=50ca5f8247448e60; RMFL=011JjUoxU106gR|U206gT; RMFW=011KKf3D; RMFD=011KKf3D; WT_FPC=id=80.202.74.192-3527246112.29947003:lv=1225887598089:ss=1225885816357; webtv.bandwidth2=5300; autoFullScreen=false; webtv.playerPlatform=0; JSESSIONID=hMnec5Qq3pb0pUPwfbSNmA**



HTTP/1.x 200 OK

Date: Wed, 05 Nov 2008 12:20:12 GMT

X-Powered-By: Servlet 2.4; JBoss-4.2.2.GA (build: SVNTag=JBoss_4_2_2_GA date=200710221139)/Tomcat-5.5

Content-Location: /webtv/metafile.asx

Content-Type: text/html; charset=ISO-8859-1

Vary: Accept-Encoding

Content-Encoding: gzip

Content-Length: 20

Connection: close


Content-Length is 20 but wget gives me a 1111 byte file:

-rw-rw-r-- 1 kmaraas kmaraas 1111 2008-11-05 13:20 metafile.asx?MSG=Uu65vkApR)RAoBHUHV4hGU5IIdHyPHjXKs2(RDwvXOi)DY(h6TAEWNrcrAUqHREutUNADsdwOfnkRKoJ)ZnUDbDMjTyGx0kwHk43jyHNN4E!
Comment 10 Bug Zapper 2008-11-25 22:00:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Harald Solheim 2009-04-01 11:45:11 EDT
This is a sample of the ASX from a valid link (the mms link in the ASX is not valid anymore): 
<ASX VERSION="3.0">
        <ABSTRACT> </ABSTRACT>
        <TITLE>Været 21:20</TITLE>
        <AUTHOR> </AUTHOR>
        <COPYRIGHT>TV 2</COPYRIGHT>
        <ENTRY>
                <TITLE>Været 21:20</TITLE>
                <ABSTRACT></ABSTRACT>
                <COPYRIGHT>TV 2</COPYRIGHT>

                <!-- StreamMetrix logging -->
                <PARAM NAME="SM/title" VALUE="Været 21:20"/>
                <PARAM NAME="SM/smsec"
VALUE="smsec=var1&smsec=var2&smsec=var3"/>

                <PARAM NAME="progId" VALUE="295288"/>

                <REF
HREF="mms://195.5.113.70/TV2_PLAY?MSG=ymXPOW1Ikp3st)etxEMOQ75ormh(bcXCop3bkw1vpbSir4TwaSmYXFZBUMWcmTceVLefnvRWFpFT2adYzOZo9Q!!&">
                </REF>
        </ENTRY>
</ASX>

The links for both the ASX and the MMS stream are updated all the time. I guess that is how the web site makes sure that only registered users can watch shows that require a subscription. 

To reproduce the bug from scratch you could use this link:
http://webtv.tv2.no/webtv/sumo/?treeId=5&progId=294392

The problem is that xulrunner (?) does not download the ASP file correctly, but leaves totem to open an empty file. When downloaded the ASP file with wget I am able to open it in totem.
Comment 12 Bastien Nocera 2009-04-01 14:35:39 EDT
Upstream bug at:
https://bugzilla.mozilla.org/show_bug.cgi?id=486346
Comment 13 Matěj Cepl 2009-04-02 08:11:57 EDT
We believe that it is more appropriate to let this bug be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.