Bug 46167 - updatedb crashes after SysVinit upgrade
updatedb crashes after SysVinit upgrade
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-27 04:03 EDT by Mark Walburn
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 10:05:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel Oops log from updatedb after sysvinit upgrade (13.61 KB, text/plain)
2001-06-27 04:11 EDT, Mark Walburn
no flags Details
Copy of /var/log/dmesg (9.82 KB, text/plain)
2001-06-28 22:13 EDT, Mark Walburn
no flags Details
Copy of lspci -vvv (9.26 KB, text/plain)
2001-06-28 22:14 EDT, Mark Walburn
no flags Details

  None (edit)
Description Mark Walburn 2001-06-27 04:03:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686; Nav)

Description of problem:
(first bugzilla submission bare with me)
Clean install of Red Hat Linux 7.1. Upgraded all rpms in 7.1 Errata section
including kernel 2.4.3-12smp. Problem occured after upgrade of
SysVinit-2.78-17.i386.rpm. Running updatedb would seg fault followed by
kernel Oops in my log files each time. Rebooting was only solution which
didn't cleanly unmount the drives so cold reboot was necessary.

How reproducible:
Didn't try


Additional info:

Jun 27 02:59:53 maya kernel: Unable to handle kernel paging request at
virtual address 00255fd4
Jun 27 02:59:53 maya kernel:  printing eip:
Jun 27 02:59:53 maya kernel: c014008c
Jun 27 02:59:53 maya kernel: pgd entry e5716000: 0000000000000000
Jun 27 02:59:53 maya kernel: pmd entry e5716000: 0000000000000000
Jun 27 02:59:53 maya kernel: ... pmd not present!
Jun 27 02:59:53 maya kernel: Oops: 0000
Jun 27 02:59:53 maya kernel: CPU:    0
Jun 27 02:59:53 maya kernel: EIP:    0010:[sys_lstat64+44/112]
Jun 27 02:59:53 maya kernel: EIP:    0010:[<c014008c>]
Jun 27 02:59:53 maya kernel: EFLAGS: 00010206
Jun 27 02:59:53 maya kernel: eax: 00255fa0   ebx: 00000000   ecx:
c2521df8   edx: ddf7ed40
Jun 27 02:59:53 maya kernel: esi: 08057fc8   edi: 00000003   ebp:
bffff668   esp: ccd61f9c
Jun 27 02:59:53 maya kernel: ds: 0018   es: 0018   ss: 0018
Jun 27 02:59:53 maya kernel: Process updatedb (pid: 7509,
stackpage=ccd61000)
Jun 27 02:59:53 maya kernel: Stack: ddf7ed40 c26833e0 08059000 00000b58
fffffff2 00000008 00000001 00000005
Jun 27 02:59:53 maya kernel:        ccd60000 c0106f3b 08057fbc bffff5f0
401599e4 08057fc8 00000003 bffff668
Jun 27 02:59:53 maya kernel:        000000c4 c010002b 0000002b 000000c4
40107e53 00000023 00000202 bffff5e0
Jun 27 02:59:53 maya kernel: Call Trace: [system_call+51/56]
[startup_32+43/203]
Jun 27 02:59:53 maya kernel: Call Trace: [<c0106f3b>] [<c010002b>]
Jun 27 02:59:53 maya kernel:
Jun 27 02:59:53 maya kernel: Code: 8b 40 34 85 c0 74 0d 52 ff d0 5a 89 c3
eb 07 90 8d 74 26 00
Comment 1 Mark Walburn 2001-06-27 04:11:35 EDT
Created attachment 21906 [details]
kernel Oops log from updatedb after sysvinit upgrade
Comment 2 Bill Nottingham 2001-06-27 23:54:05 EDT
assigning to kernel.
Comment 3 Arjan van de Ven 2001-06-28 04:52:43 EDT
To be clear: so 2.4.2-2 worked fine.

Could you give me a brief overview of the system?
(eg cpu type, memory etc; the output of "lspci" would also give a lot of basic
information about your system)
Comment 4 Mark Walburn 2001-06-28 22:11:41 EDT
Yes the stock 2.4.2-2 worked properly. I must of run updatedb half a dozen times
with that kernel without problems. Only after I upgraded SysVinit from errata
did these incidents occur.

My system is an Asus CUV4X-DLS (VIA 694XDP 133MHz AGPset with VT82C686B South
Bridge) Dual Socket 370 Pentium III 1Ghz 133/fsb (only 1 P3 1ghz seeded
currently) 1Gig of PC133 CL-3, 7.5ns, Registered ECC SDRAM from Crucial.com.
I'll attach a copy of dmesg and lspci as per request. 

Comment 5 Mark Walburn 2001-06-28 22:13:08 EDT
Created attachment 22146 [details]
Copy of /var/log/dmesg
Comment 6 Mark Walburn 2001-06-28 22:14:31 EDT
Created attachment 22147 [details]
Copy of lspci -vvv
Comment 7 Arjan van de Ven 2001-07-02 04:24:05 EDT
This seems to be repeatable. Could you try booting with adding "ide=nodma"
to the lilo prompt? Same for "noapic". Both are known to fix issues with
certain VIA chipsets.
Comment 8 Alan Cox 2003-06-06 10:05:05 EDT
Closing: old bug, seems to be the long fixed VIA chipset hardware thing

Note You need to log in before you can comment on or make changes to this bug.