Bug 461670 - Can't update libgsf
Can't update libgsf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libgsf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 15:41 EDT by Andreas Tunek
Modified: 2008-09-11 13:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 13:21:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Tunek 2008-09-09 15:41:57 EDT
Description of problem:
Can't update libgsf using yum update.

Version-Release number of selected component (if applicable):
1.14.9-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. Run yum update
2. Watch it fail.
3. Loose?
  
Actual results:
See below.

Expected results:
An updated libgsf.

Additional info:
Yum output:

#yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libgsf-gnome.i386 0:1.14.9-1.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch         Version               Repository       Size 
================================================================================
Updating:
 libgsf-gnome         i386         1.14.9-1.fc10         rawhide           22 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 22 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  fil /etc/gconf/schemas/gsf-office-thumbnailer.schemas från installation av libgsf-gnome-1.14.9-1.fc10.i386 står i konflikt med filen från paket libgsf-1.14.8-1.fc9.i386
  fil /usr/bin/gsf-office-thumbnailer från installation av libgsf-gnome-1.14.9-1.fc10.i386 står i konflikt med filen från paket libgsf-1.14.8-1.fc9.i386
  fil /usr/share/man/man1/gsf-office-thumbnailer.1.gz från installation av libgsf-gnome-1.14.9-1.fc10.i386 står i konflikt med filen från paket libgsf-1.14.8-1.fc9.i386

Error Summary
-------------


Sorry for the swedish...
Comment 1 Caolan McNamara 2008-09-09 16:26:04 EDT
It looks very odd that libgsf isn't *also* being updated from the fc9 version to the f10 at the same time as the libgsf-gnome is is getting updated. In which case the move of the thumbnailer from libgsf to libgsf-gnome should be ok, i.e. *new* libgsf doesn't conflict with *new* libgsf-gnome, while *old* libgsf does conflict with *new* libgsf-gnome.

What does 

rpm -q --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n' libgsf libgsf-gnome

say ?
Comment 2 Andreas Tunek 2008-09-10 14:31:02 EDT
#rpm -q --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n' libgsf
libgsf-1.14.8-1.fc9-i386
libgsf-1.14.8-2.fc10-i386
libgsf-1.14.9-1.fc10-i386

# rpm -q --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n' libgsf-gnome
libgsf-gnome-1.14.8-1.fc9-i386
libgsf-gnome-1.14.8-2.fc10-i386

Thanks for the help!
Comment 3 Caolan McNamara 2008-09-10 17:15:21 EDT
So you've got way too many duplicates going on there, perhaps from an earlier failed yum like a crash during upgrade from 1.14.8-1 to 1.14.8-2, so try...

something like...

rpm --erase libgsf-1.14.8-1.fc9-i386 libgsf-gnome-1.14.8-1.fc9-i386 libgsf-1.14.9-1.fc10-i386

to get a consistent pair of libgsf-gnome-1.14.8-2.fc10-i386 + libgsf-1.14.8-2.fc10-i386 and then yum update again and yum should get the two new 1.14.9-1 version replacements

that should work in theory at least :-)
Comment 4 Andreas Tunek 2008-09-11 13:21:16 EDT
I did package-cleanup --cleandupes libgsf and 
package-cleanup --cleandupes libgsf-gnome
which solved all problems.

Thanks for the help!

Note You need to log in before you can comment on or make changes to this bug.