Bug 461673 - the genomeized environment only kinda sorta checks system credentials for yum
the genomeized environment only kinda sorta checks system credentials for yum
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Client Tools (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Network Quality Assurance
us=44797
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 15:46 EDT by Stephen Herr
Modified: 2013-01-10 04:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 16:00:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2008-09-09 15:46:30 EDT
Description of problem:
The genome environment will check a system's credentials when using yum. It clearly checks them, because yum will throw the expected Invalid System Credentials error if something's wrong, but then it'll go ahead and do whatever you asked it to anyway.

How reproducible:
Always

Steps to Reproduce:
1. Point a RHEL 5 box to xmlrpc.rhntest.intdev.redhat.com
2. Either don't register it or register it and change the systemid
3. Try running a yum command, such as 'yum list available' or 'yum update'
  
Actual results:
Yum throws an Invalid System Credentials error, and continues to do whatever you asked it.

Expected results:
Yum throws an Invalid System Credentials error and stops.
Comment 1 Stephen Herr 2008-09-09 16:00:52 EDT
Oops, embarrassing mistake on my part. There were other repos set up that I wasn't aware of, and they were the ones that were being listed/updated after the error was thrown.

Note You need to log in before you can comment on or make changes to this bug.