Bug 461718 - xorg-x11-server-Xephyr missing in sugar requires in Fedora 9
xorg-x11-server-Xephyr missing in sugar requires in Fedora 9
Status: CLOSED WONTFIX
Product: Fedora OLPC
Classification: Retired
Component: sugar (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Fedora Extras Quality Assurance
:
: 452208 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 02:05 EDT by Andrew Puch
Modified: 2013-04-02 00:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 03:11:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Puch 2008-09-10 02:05:43 EDT
Description of problem: Missing package on normal fedora install of 


Version-Release number of selected component (if applicable):


How reproducible: %100 
 sugar-emulator 
INFO:sugar-emulator:Attempting to find free port for X11 (Xephyr)
INFO:sugar-emulator:  Found free port: #1 (6001)
INFO:sugar-emulator:Starting the Xephyr nested X display on display 1
DEBUG:sugar-emulator:Xephyr command: Xephyr :1 -ac -screen 1200x900 -dpi 133
Traceback (most recent call last):
  File "/usr/bin/sugar-emulator", line 24, in <module>
    main()
  File "/usr/share/sugar/shell/emulator.py", line 125, in main
    _start_xephyr()
  File "/usr/share/sugar/shell/emulator.py", line 85, in _start_xephyr
    result = gobject.spawn_async(cmd, flags=gobject.SPAWN_SEARCH_PATH)
gobject.GError: Failed to execute child process "Xephyr" (No such file or directory)


Steps to Reproduce:
1.
2.
3.
  
Actual results:
 sugar-emulator 
INFO:sugar-emulator:Attempting to find free port for X11 (Xephyr)
INFO:sugar-emulator:  Found free port: #1 (6001)
INFO:sugar-emulator:Starting the Xephyr nested X display on display 1
DEBUG:sugar-emulator:Xephyr command: Xephyr :1 -ac -screen 1200x900 -dpi 133
Traceback (most recent call last):
  File "/usr/bin/sugar-emulator", line 24, in <module>
    main()
  File "/usr/share/sugar/shell/emulator.py", line 125, in main
    _start_xephyr()
  File "/usr/share/sugar/shell/emulator.py", line 85, in _start_xephyr
    result = gobject.spawn_async(cmd, flags=gobject.SPAWN_SEARCH_PATH)
gobject.GError: Failed to execute child process "Xephyr" (No such file or directory)


Expected results:


Additional info:

Simple fix to the requires for sugar , or a sugar-emulator package 

with this requires. 
 xorg-x11-server-Xephyr
Comment 1 Simon Schampijer 2008-09-10 03:06:23 EDT
The sugar-emulator with the dependency on xephyr has been split into a separate package in 0.81.6-4 - currently on my F9 machine the sugar version is 0.81.3-1. Looks like we have to make the latest packages available in F-9
Comment 2 Alexander Todorov 2008-10-28 04:47:30 EDT
*** Bug 452208 has been marked as a duplicate of this bug. ***
Comment 4 Simon Schampijer 2009-02-25 03:11:46 EST
It has been fixed in F10 - we do not have the man power to fix it for F9, sorry :/

Note You need to log in before you can comment on or make changes to this bug.