Bug 461719 - mt-daapd init.d script is broken
mt-daapd init.d script is broken
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: 4Suite (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: W. Michael Petullo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 02:23 EDT by Adam Pribyl
Modified: 2008-10-20 16:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 16:27:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mt-daapd init script patch (528 bytes, patch)
2008-09-10 02:23 EDT, Adam Pribyl
no flags Details | Diff

  None (edit)
Description Adam Pribyl 2008-09-10 02:23:10 EDT
With existing init.d script it is not possible to cleanly restart mt-daapd and is not giving out the [OK/FAIL] output for stop.

Attached is a patch.
Comment 1 Adam Pribyl 2008-09-10 02:23:54 EDT
Created attachment 316278 [details]
mt-daapd init script patch
Comment 2 W. Michael Petullo 2008-09-25 21:11:16 EDT
What's with the "sleep 2" for restart / reload? Can this be avoided?
Comment 3 Adam Pribyl 2008-09-26 04:59:24 EDT
I do not know exactly why, but it is needed for me. It probably takes some time for mt-daap to clean up. Without it, mt-daap will not start. I understand that this could depend on computer performace and could cause that it will fail on different computer anyway. This way it at least works for me. Existing way is not working at all. You can try this at your PC without sleep.
Comment 4 Fedora Update System 2008-09-26 22:44:15 EDT
mt-daapd-0.2.4.2-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/mt-daapd-0.2.4.2-3.fc9
Comment 5 Fedora Update System 2008-09-26 22:44:18 EDT
mt-daapd-0.2.4.2-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/mt-daapd-0.2.4.2-3.fc8
Comment 6 Fedora Update System 2008-10-01 02:38:09 EDT
mt-daapd-0.2.4.2-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mt-daapd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8473
Comment 7 Fedora Update System 2008-10-01 02:39:52 EDT
mt-daapd-0.2.4.2-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mt-daapd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8486
Comment 8 Fedora Update System 2008-10-20 16:27:12 EDT
mt-daapd-0.2.4.2-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-10-20 16:30:29 EDT
mt-daapd-0.2.4.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.