Bug 461768 - Wrong answers for AAAA-query can lead to cache-problems
Wrong answers for AAAA-query can lead to cache-problems
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: pdns (Show other bugs)
el5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 10:18 EDT by Stefan Neufeind
Modified: 2008-10-04 09:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-04 09:56:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-09-10 10:18:18 EDT
See:
http://wiki.powerdns.com/cgi-bin/trac.fcgi/ticket/125

Already fixed upstream since quite a while now:
http://wiki.powerdns.com/cgi-bin/trac.fcgi/changeset/1081
Comment 1 Ruben Kerkhof 2008-09-12 07:24:20 EDT
Already fixed in Fedora since a while now:
http://download.fedora.redhat.com/pub/epel/5/i386/repoview/pdns.html
Comment 2 Stefan Neufeind 2008-09-12 07:30:46 EDT
This is _not_ the case. 2.9.21 didn't include the fix and 2.9.21.1 is just kind of a "re-release" to fix a different issue. The official version doesn't have the fix as well and since that there is the bug on their side still open as well.

We're running a self-patched 2.9.21.1 from epel with the fix from the above mentioned ticket applied. And that definitely solved the problem. The fix is minor, but has a big impact in case AAAA is used.

If needed I can elaborate more on the details of the issue, but that's generally also reflected in the ticket.
Comment 3 Ruben Kerkhof 2008-09-12 08:55:43 EDT
Ah, sorry. I'll build a new version with the patch from changeset 1081.
Comment 4 Stefan Neufeind 2008-10-04 06:15:26 EDT
Ruben, thank you for building a new release for Fedora 9. Could you please also re-roll the EPEL-packages?
Comment 5 Ruben Kerkhof 2008-10-04 09:56:19 EDT
Hi Stefan,

I've build them a while ago, and they're in EPEL testing, but unfortunately there hasn't been a push to stable in a while.
You can grep them from the epel-testing repo in the meantime
http://download.fedora.redhat.com/pub/epel/testing/5/i386/pdns-2.9.21.1-2.el5.i386.rpm

Note You need to log in before you can comment on or make changes to this bug.