Bug 461780 - Nagios free RAM check on the installer node broken
Nagios free RAM check on the installer node broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat HPC Solution
Classification: Red Hat
Component: nagios-mem-plugin (Show other bugs)
5.1
All Linux
high Severity urgent
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 11:17 EDT by Daniel Riek
Modified: 2008-09-15 13:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 13:39:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2008-09-10 11:17:16 EDT
Nagios free ram check on the installer node fails in the default installation:

[1221058190] Warning: Return code of 127 for check of service 'Free RAM' on host 'ibm-ridgeback' was out of bounds. Make sure the plugin you're trying to run actually exists.
Comment 1 Daniel Riek 2008-09-10 11:27:35 EDT
The actual problem seems to be that check_mem was installed into /usr/lib/nagios/plugins/ instead of /usr/lib64/nagios/plugins/ :

[root@installer nagios]# ls /usr/lib/nagios/plugins/
check_mem

All other plugins are in lib64
Comment 2 Daniel Riek 2008-09-11 13:02:39 EDT
We should fix this before release.
Comment 3 OCS Support 2008-09-11 15:54:28 EDT
Updated SRPM has been posted to Nils.  Waiting for build and post to the channel...
Comment 4 Daniel Riek 2008-09-15 13:39:32 EDT
Verified. Closing.

Note You need to log in before you can comment on or make changes to this bug.