Bug 461837 - bootchart.jar no longer rendering
bootchart.jar no longer rendering
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bootchart (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 17:09 EDT by Jason Farrell
Modified: 2008-11-27 16:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-27 16:45:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2008-09-10 17:09:37 EDT
Description of problem:
the bootchart jar is no longer able to render the generated bootchart.tgz to png. both openjdk and sun java fail in the same way.

Version-Release number of selected component (if applicable):
bootchart-0.9-9.fc9.x86_64
java-1.6.0-openjdk-1.6.0.0-0.16.b09.fc9.x86_64
  or
jre-6u10-rc-bin-b28-linux-i586-21_jul_2008.bin


I do recall this working in previous in fedora releases, but no longer (the online renderers are down atm too). e.g.:

[jaf@nano:0j:158h:0e:0.07MB acer-aspire-one-f9]$ java -jar /usr/share/java/bootchart.jar bootchart.tgz
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/cli/ParseException
Caused by: java.lang.ClassNotFoundException: org.apache.commons.cli.ParseException
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
Comment 1 Jason Farrell 2008-11-27 16:45:27 EST
Fine with /usr/bin/bootchart java helperscript

Note You need to log in before you can comment on or make changes to this bug.