Bug 461893 - This package includes a /usr/bin/ispell wich is incompatible to ispell
This package includes a /usr/bin/ispell wich is incompatible to ispell
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: aspell (Show other bugs)
5.4
All Linux
medium Severity high
: rc
: ---
Assigned To: Peter Schiffer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 04:52 EDT by Klaus Ethgen
Modified: 2013-04-12 15:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-07 11:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Ethgen 2008-09-11 04:52:47 EDT
Description of problem:
The package aspell includes a "compatibility script" /usr/bin/ispell witch is
totally incompatible to ispell.

This is that more important if one like to compile ispell by himself and
install it as package as there cannot be two (installed) packages providing the
same binary.

Version-Release number of selected component (if applicable):
Since long time. That issue was still in RHEL4

Additional info:
There is a entry in the changelog refering the bug #90907 which is unreadable.
(Oh, I forgot that moving a script from /usr/share to /usr/bin has a security
impact!)
Comment 2 Peter Schiffer 2011-09-07 11:42:26 EDT
Closing this as WONTFIX because ispell project is inactive for 6 years now, there is no rpm package of it for RHEL and /usr/bin/ispell compatibility script is part of upstream aspell project.

If you need to build your custom binaries, you should place them to the /usr/local so they don't conflict with the system binaries.

Note You need to log in before you can comment on or make changes to this bug.