Bug 461901 - rcp does not return ENOSPC error on full NFS-File system
rcp does not return ENOSPC error on full NFS-File system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rsh (Show other bugs)
4.6
All Linux
urgent Severity high
: rc
: ---
Assigned To: Adam Tkac
qe-baseos-daemons
: EasyFix, Patch, ZStream
Depends On:
Blocks: 509363
  Show dependency treegraph
 
Reported: 2008-09-11 05:54 EDT by Tomas Smetana
Modified: 2013-04-30 19:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 16:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch for rsh-0.17-25.4 (541 bytes, patch)
2008-09-11 05:54 EDT, Tomas Smetana
no flags Details | Diff

  None (edit)
Description Tomas Smetana 2008-09-11 05:54:33 EDT
Created attachment 316407 [details]
Proposed patch for rsh-0.17-25.4

When using rcp to copy files to/from a NFS volume rcp doesn't report an error if the filesystem is full already, e.g.:

rcp biglocalfile remoteserver:/nfsshare/

Where bigfile is big enough to fill the "nfsshare", no error appears.  This may lead to silent data loss.

This is caused by NFS not reporting an error (ENOSPC) during write(2) but just in the close(2) calls (more info in the close manual page).
Comment 1 Tomas Smetana 2008-09-11 05:55:41 EDT
The same bug for krb5: bug #461900
Comment 2 Adam Tkac 2008-09-16 07:17:40 EDT
Right you are and thanks for patch, looks fine for me
Comment 3 RHEL Product and Program Management 2008-10-31 12:44:39 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Note You need to log in before you can comment on or make changes to this bug.