Bug 461903 - rcp does not return ENOSPC error on full NFS-File system
rcp does not return ENOSPC error on full NFS-File system
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rsh (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Tkac
Ben Levenson
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 06:16 EDT by Tomas Smetana
Modified: 2014-10-15 07:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 05:57:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Smetana 2008-09-11 06:16:08 EDT
+++ This bug was initially created as a clone of Bug #461901 +++

Created an attachment (id=316407)
Proposed patch for rsh-0.17-25.4

When using rcp to copy files to/from a NFS volume rcp doesn't report an error if the filesystem is full already, e.g.:

rcp biglocalfile remoteserver:/nfsshare/

Where bigfile is big enough to fill the "nfsshare", no error appears.  This may lead to silent data loss.

This is caused by NFS not reporting an error (ENOSPC) during write(2) but just in the close(2) calls (more info in the close manual page).
Comment 1 Tomas Smetana 2008-09-11 06:17:00 EDT
The related krb5 bug #461902
Comment 2 Adam Tkac 2008-09-16 07:18:22 EDT
Right you are and thanks for patch, looks fine for me
Comment 9 errata-xmlrpc 2009-04-15 05:57:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0423.html

Note You need to log in before you can comment on or make changes to this bug.