Bug 461904 - ioctl default minimum argument length of 256 should be restored
ioctl default minimum argument length of 256 should be restored
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl (Show other bugs)
5.2.z
ppc64 Linux
medium Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 06:16 EDT by Petr Šplíchal
Modified: 2016-05-31 21:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 10:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testcase (184 bytes, text/plain)
2008-09-11 06:20 EDT, Petr Šplíchal
no flags Details
updated testcase (214 bytes, text/plain)
2008-09-11 06:20 EDT, Petr Šplíchal
no flags Details

  None (edit)
Comment 1 Petr Šplíchal 2008-09-11 06:20:04 EDT
Created attachment 316408 [details]
testcase
Comment 2 Petr Šplíchal 2008-09-11 06:20:46 EDT
Created attachment 316409 [details]
updated testcase
Comment 6 Stepan Kasal 2009-03-17 11:18:16 EDT
Since this started as a report that the check for bug 185240 fails in a strange way on ppc, here is a hack that fills the gap in sys/ioctl.ph

# redefine broken _IOC_TYPECHECK macro
sub _IOC_TYPECHECK {
  $sizeof{$_[0]} or do {
    # can't die because we're being eval-ed by _IOR or _IOW
    print STDERR "invalid size argument for IOC: \%sizeof contains no '$_[0]' ke
    exit 1;
  }
}

# define a sizeof hash
%sizeof = (
        int => 4, 'unsigned int' => 4, 'struct winsize' => 8,
)
Comment 7 Stepan Kasal 2009-03-17 11:39:31 EDT
I forgot to give proper credit; the workaroud presented in comment #6 comes from a comment by Kevin Buhr:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=190887#15

Note You need to log in before you can comment on or make changes to this bug.