Bug 461950 - Dependency resolution failure error attempting install of gscan2pdf-0.9.23-1.fc9 (noarch)
Dependency resolution failure error attempting install of gscan2pdf-0.9.23-1....
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: gscan2pdf (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 12:19 EDT by Diccon Spain
Modified: 2008-11-18 21:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-18 21:18:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diccon Spain 2008-09-11 12:19:10 EDT
Description of problem:

When attempting to install gscan2pdf-0.9.23-1.fc9 (noarch) through Add/Remove Software - Packagekit complains about missing perl package: perl-libs4:5.10.0-31.fc9 even though a more up to date version is available: perl-libs4:5.10.0-33.fc9

PackageKit Error

A package could not be found that allows the task to complete...

perl = 4:5.10.0-31.fc9 is needed by package perl-ExtUtils-MakeMaker-6.36-31.fc9.i386 (updates-newkey)
perl = 4:5.10.0-31.fc9 is needed by package 4:perl-devel-5.10.0-31.fc9.i386 (updates-newkey)
perl = 4:5.10.0-31.fc9 is needed by package perl-Test-Simple-0.72-31.fc9.i386 (updates-newkey)
perl = 4:5.10.0-31.fc9 is needed by package perl-Test-Harness-2.64-31.fc9.i386 (updates-newkey)
perl = 4:5.10.0-31.fc9 is needed by package 1:perl-ExtUtils-ParseXS-2.18-31.fc9.i386 (updates-newkey)

Version-Release number of selected component (if applicable):
gscan2pdf-0.9.23-1.fc9 (noarch)

How reproducible:

Install gscan2pdf-0.9.23-1.fc9 (noarch) through Add/Remove Software

Steps to Reproduce:
1. Install gscan2pdf-0.9.23-1.fc9 (noarch) through Add/Remove Software
  
Actual results:

PackageKit Error

A package could not be found that allows the task to complete...

perl = 4:5.10.0-31.fc9 is needed by package perl-ExtUtils-MakeMaker-6.36-31.fc9.i386 (updates-newkey)
perl = 4:5.10.0-31.fc9 is needed by package 4:perl-devel-5.10.0-31.fc9.i386 (updates-newkey)
perl = 4:5.10.0-31.fc9 is needed by package perl-Test-Simple-0.72-31.fc9.i386 (updates-newkey)
perl = 4:5.10.0-31.fc9 is needed by package perl-Test-Harness-2.64-31.fc9.i386 (updates-newkey)
perl = 4:5.10.0-31.fc9 is needed by package 1:perl-ExtUtils-ParseXS-2.18-31.fc9.i386 (updates-newkey)

Expected results:
Successful install of gscan2pdf-0.9.23-1.fc9 package.

Additional info:
Comment 1 Bernard Johnson 2008-11-12 23:25:15 EST
Possibly a PackageKit bug since gscan2pdf doesn't depend on perl-libs4:

$ rpm -q --requires gscan2pdf
/bin/sh  
/bin/sh  
/usr/bin/perl  
djvulibre  
gocr  
perl(:MODULE_COMPAT_5.10.0)  
perl(Archive::Tar)  
perl(Carp)  
perl(Config::General) >= 2.40
perl(Cwd)  
perl(Data::Dumper)  
perl(Exporter)  
perl(File::Basename)  
perl(File::Copy)  
perl(File::Temp)  
perl(FileHandle)  
perl(Glib)  
perl(Gscan2pdf)  
perl(Gtk2)  
perl(Gtk2::Ex::PodViewer)  
perl(Gtk2::Ex::Simple::List)  
perl(Gtk2::Gdk::Keysyms)  
perl(Gtk2::ImageView)  
perl(Image::Magick)  
perl(Locale::gettext) >= 1.05
perl(PDF::API2)  
perl(POSIX)  
perl(Socket)  
perl(Text::ParseWords)  
perl(Time::Local)  
perl(strict)  
perl(utf8)  
perl(warnings)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
sane-backends >= 1.0.17
sane-frontends  
unpaper  
xdg-utils
Comment 2 Richard Hughes 2008-11-13 09:52:03 EST
Not a packageKit bug. PackageKit doesn't do depsolving.
Comment 3 Bernard Johnson 2008-11-13 10:53:52 EST
Any idea what package to file this bug with?
Comment 4 Bernard Johnson 2008-11-18 21:18:41 EST
Sorry, it doesn't appear to be a gscan2pdf package bug and I can't reproduce it.  If you are still having this issue, test installing using yum and see if you get the same results.

Note You need to log in before you can comment on or make changes to this bug.