Bug 461956 - Terrible clustat / clusvcadm performance.
Terrible clustat / clusvcadm performance.
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: ZStream
Depends On:
Blocks: 496671
  Show dependency treegraph
 
Reported: 2008-09-11 12:50 EDT by Lon Hohberger
Modified: 2010-10-23 00:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (2.13 KB, patch)
2008-09-11 12:50 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2008-09-11 12:50:44 EDT
Created attachment 316459 [details]
Fix

Description of problem:

Each one of these requires several seconds longer to complete than expected.

Version-Release number of selected component (if applicable): 1.9.80

How reproducible: 50%

This is caused by the event threading sleeping with a lock held when it should be doing a pthread_cond_timedwait()
Comment 1 Lon Hohberger 2009-02-19 11:53:32 EST
This bug could cause temporary leaks in file descriptors, and if lots of services are in place, it could in theory cause rgmanager to run out of file descriptors (which should never happen).
Comment 2 Lon Hohberger 2009-02-19 11:54:01 EST
After rgmanager wakes up from the sleep(), it should correctly close these file descriptors of course.
Comment 7 errata-xmlrpc 2009-05-18 17:12:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1048.html

Note You need to log in before you can comment on or make changes to this bug.