Bug 461957 - evolution-brutus Failure to build from source
evolution-brutus Failure to build from source
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-brutus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On: 463092
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 13:03 EDT by Jesse Keating
Modified: 2013-01-09 22:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-22 19:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-09-11 13:03:09 EDT
evolution-brutus fails when building, looks like something wrong in the use of evolution-data-server headers:

 gcc -DHAVE_CONFIG_H -I. -I.. -I/builddir/build/BUILD/evolution-brutus-1.2.17 -I/builddir/build/BUILD/evolution-brutus-1.2.17/idl -I/builddir/build/BUILD/evolution-brutus-1.2.17/idl_output -I/usr/include/evolution-data-server-2.24 -I-I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -DORBIT2=1 -pthread -I/usr/include/evolution-data-server-2.24 -I/usr/include/libgnome-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/gconf/2 -I/usr/include/libsoup-2.4 -I/usr/include/gtk-2.0 -I/usr/include/libglade-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2 -DBRUTUS_LOCALEDIR=\"/usr/share/locale\" -DG_LOG_DOMAIN=\"camel-brutus-provider\" -DCAMEL_EXPLICIT_TRANSLATION_DOMAIN=\"evolution-brutus-2.24\" -DORBIT2_EXTENSIONS -fno-strict-aliasing -I/usr/include/brutus-keyring-1.0 -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/orbit-2.0 -I/usr/include/libIDL-2.0 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Werror -Werror-implicit-function-declaration -Wundef -Wbad-function-cast -Wcast-align -Wmissing-declarations -std=gnu89 -D_REENTRANT -I/usr/include/ImageMagick -I/usr/include/evolution-data-server-2.24 -MT camel-brutus-provider.lo -MD -MP -MF .deps/camel-brutus-provider.Tpo -c camel-brutus-provider.c  -fPIC -DPIC -o .libs/camel-brutus-provider.o
In file included from /usr/include/evolution-data-server-2.24/camel/camel-folder-summary.h:30
,
                 from /usr/include/evolution-data-server-2.24/camel/camel-folder.h:30
,
                 from camel-brutus-folder-summary.h:30
,
                 from camel-brutus-folder-summary.c:45
:
/usr/include/evolution-data-server-2.24/camel/camel-db.h:19:5:
 
error: 
"CAMEL_DB_DEBUG" is not defined
In file included from /usr/include/evolution-data-server-2.24/camel/camel-folder-summary.h:30,
                 from /usr/include/evolution-data-server-2.24/camel/camel-folder.h:30,
                 from camel-brutus-folder.c:39:
/usr/include/evolution-data-server-2.24/camel/camel-db.h:19:5: error: "CAMEL_DB_DEBUG" is not defined
In file included from /usr/include/evolution-data-server-2.24/camel/camel-store.h:35,
                 from camel-brutus-store.c:42:
/usr/include/evolution-data-server-2.24/camel/camel-db.h:19:5: error: "CAMEL_DB_DEBUG" is not defined
camel-brutus-folder-summary.c: In function 'brutus_update_folder_summary':
camel-brutus-folder-summary.c:1947: error: 'CamelFolderSummary' has no member named 'messages'
camel-brutus-folder-summary.c:1953: error: 'CamelFolderSummary' has no member named 'messages'
camel-brutus-folder-summary.c:1961: error: 'CamelFolderSummary' has no member named 'messages'
In file included from /usr/include/evolution-data-server-2.24/camel/camel-store.h:35,
                 from camel-brutus-store.h:32,
                 from camel-brutus-provider.c:43:
/usr/include/evolution-data-server-2.24/camel/camel-db.h:19:5: 
error: "CAMEL_DB_DEBUG" is not defined


http://koji.fedoraproject.org/koji/getfile?taskID=820691&name=build.log
Comment 1 Jules Colding 2008-09-11 14:50:43 EDT
Hmm, this is the one bit that fails from camel-db.h:

struct _CamelDB {
        sqlite3 *db;
        GMutex *lock;
        const char *sort_by;
        const char *collate;
        CamelDBCollate collate_cb;
#if CAMEL_DB_DEBUG      
        GTimer *timer;
#endif  
};


Why do this not compile?
Comment 2 Jules Colding 2008-09-11 15:08:27 EDT
OK, upstream fails in different ways, but I can now see that the "messages" struct member is gone. I'll take a look at it later.
Comment 3 Jesse Keating 2008-09-11 15:55:54 EDT
Please be aware that we're entering into the Fedora 10 Beta freeze later this evening, and evolution-brutus has broken deps in rawhide right now.
Comment 4 Matthew Barnes 2008-09-11 17:46:37 EDT
I've ranted about this to the upstream folks.  See
http://bugzilla.gnome.org/show_bug.cgi?id=543389#c39

Hopefully we can get this addressed before the code freeze.
Comment 5 Jules Colding 2008-09-12 11:17:00 EDT
Exactly, referring to an "#if 0" block as a deprecation is the understatement of the year. Anyway, I'm working on a buildfix for e-b. Hopefully I can do it in time for the freeze...
Comment 6 Jules Colding 2008-09-12 12:33:20 EDT
I've fixed this upstream. Please update.

Thanks,
  jules
Comment 8 Alex Lancaster 2008-09-21 06:22:34 EDT
(In reply to comment #6)
> I've fixed this upstream. Please update.

Is 1.2.20 supposed to the latest upstream?
Comment 10 Jules Colding 2008-09-21 08:10:40 EDT
The build was fixed in 1.2.26 as far as I remember. I've build 1.2.26 successfully on rawhide.
Comment 11 Jules Colding 2008-09-21 08:55:22 EDT
The new 1.2.27 RPMs are here:

http://www.42tools.com/sites/default/files/downloads/dist/evolution-brutus/Rawhide/


BTW, I'm sorry that you wasn't able to find the right source instantly. It should never be the case that you are forced to "hunt around" and generally wasting your time to find what should be easily available.

Sorry,
  jules
Comment 12 Alex Lancaster 2008-09-21 09:02:05 EDT
Thanks, but it seems that 1.2.27 still fails to build on rawhide:

https://koji.fedoraproject.org/koji/taskinfo?taskID=834842

does this also require the new brutus-keyring ?
Comment 13 Alex Lancaster 2008-09-21 09:09:53 EDT
Actually it looks like the latest brutus-keyring-0.9.30-1.fc10 is already in rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=61893
Comment 14 Jules Colding 2008-09-21 09:29:59 EDT
(In reply to comment #12)
> Thanks, but it seems that 1.2.27 still fails to build on rawhide:
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=834842

Due to a bug in eds:

http://svn.gnome.org/viewvc/evolution-data-server/trunk/camel/camel-db.h?r1=9402&r2=9527
 
> does this also require the new brutus-keyring ?

No.
Comment 15 Alex Lancaster 2008-09-21 09:38:14 EDT
(In reply to comment #14)
> (In reply to comment #12)
> > Thanks, but it seems that 1.2.27 still fails to build on rawhide:

> > https://koji.fedoraproject.org/koji/taskinfo?taskID=834842

> Due to a bug in eds:
> http://svn.gnome.org/viewvc/evolution-data-server/trunk/camel/camel-db.h?r1=9402&r2=9527

Argh.  Does this mean evolution-brutus cannot build unless this fix is applied to e-d-s?  Is there a temporary workaround we can put in evolution-brutus?  Otherwise can you open up a bug on e-d-s and have that bug block this one?
Comment 16 Jules Colding 2008-09-21 10:01:59 EDT
It can't build before the patch above is applied. I've added a new bug and a dependency.
Comment 17 Alex Lancaster 2008-09-21 10:16:36 EDT
(In reply to comment #16)
> It can't build before the patch above is applied. I've added a new bug and a
> dependency.

Great, thanks.  Hopefully the e-d-s maintainers will get on it soon.
Comment 18 Jules Colding 2008-09-21 14:05:35 EDT
Hmm... did you just remove the dependency on #461957?
Comment 19 Alex Lancaster 2008-09-21 17:54:30 EDT
(In reply to comment #18)
> Hmm... did you just remove the dependency on #461957?

Sorry about that, I think I didn't refresh the page before adding comment #17, which had the net effect of removing the bug.  Re-added.
Comment 20 Brian Pepple 2008-09-22 19:55:49 EDT
Package rebuilt by Alex.  Thanks!

http://koji.fedoraproject.org/koji/buildinfo?buildID=63784

Note You need to log in before you can comment on or make changes to this bug.