Bug 462030 - b43 wireless stopped working
b43 wireless stopped working
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: b43-fwcutter (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 23:11 EDT by hadmanysons
Modified: 2008-09-12 09:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 09:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hadmanysons 2008-09-11 23:11:44 EDT
Description of problem: After installing a recent update (which one I can't remember, it was among 400), my wireless card stopped working. It's a b43 type (4306).


Version-Release number of selected component (if applicable):
b43-fwcutter version 011
NetworkManager 0.7.0
How reproducible:


Steps to Reproduce:
1. b43-fwcutter
2. modprobe.conf "alias wlan0 b43"
3. modprobe b43
  
Actual results:
This is was dmesg says "
input: b43-phy0 as /devices/virtual/input/input8
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0 debug: Chip initialized
b43-phy0 debug: 30-bit DMA initialized
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
Registered led device: b43-phy0::radio
b43-phy0 debug: Wireless interface started
b43-phy0 debug: Adding Interface type 2
ADDRCONF(NETDEV_UP): wlan0: link is not ready
eth0: no IPv6 routers present
b43-phy0 debug: Removing Interface type 2
b43-phy0 debug: Wireless interface stopped
b43-phy0 debug: DMA-30 rx_ring: Used slots 0/64, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy0 debug: DMA-30 tx_ring_AC_BK: Used slots 0/128, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy0 debug: DMA-30 tx_ring_AC_BE: Used slots 0/128, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy0 debug: DMA-30 tx_ring_AC_VI: Used slots 0/128, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy0 debug: DMA-30 tx_ring_AC_VO: Used slots 20/128, Failed frames 0/88 = 0.0%, Average tries 0.90
b43-phy0 debug: DMA-30 tx_ring_mcast: Used slots 0/128, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy1: Broadcom 4306 WLAN found
b43-phy1 debug: Found PHY: Analog 2, Type 2, Revision 2
b43-phy1 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2
phy1: Selected rate control algorithm 'pid'
Broadcom 43xx driver loaded [ Features: PMLR, Firmware-ID: FW13 ]
input: b43-phy1 as /devices/virtual/input/input9
b43-phy1: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy1 debug: Chip initialized
b43-phy1 debug: 30-bit DMA initialized
Registered led device: b43-phy1::tx
Registered led device: b43-phy1::rx
Registered led device: b43-phy1::radio
b43-phy1 debug: Wireless interface started
b43-phy1 debug: Adding Interface type 2
ADDRCONF(NETDEV_UP): wlan0: link is not ready
b43-phy1 debug: Removing Interface type 2
b43-phy1 debug: Wireless interface stopped
b43-phy1 debug: DMA-30 rx_ring: Used slots 0/64, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy1 debug: DMA-30 tx_ring_AC_BK: Used slots 0/128, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy1 debug: DMA-30 tx_ring_AC_BE: Used slots 0/128, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy1 debug: DMA-30 tx_ring_AC_VI: Used slots 0/128, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy1 debug: DMA-30 tx_ring_AC_VO: Used slots 16/128, Failed frames 0/737 = 0.0%, Average tries 0.96
b43-phy1 debug: DMA-30 tx_ring_mcast: Used slots 0/128, Failed frames 0/0 = 0.0%, Average tries 0.00
b43-phy2: Broadcom 4306 WLAN found
b43-phy2 debug: Found PHY: Analog 2, Type 2, Revision 2
b43-phy2 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2
phy2: Selected rate control algorithm 'pid'
Broadcom 43xx driver loaded [ Features: PMLR, Firmware-ID: FW13 ]
input: b43-phy2 as /devices/virtual/input/input10
b43-phy2: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy2 debug: Chip initialized
b43-phy2 debug: 30-bit DMA initialized
Registered led device: b43-phy2::tx
Registered led device: b43-phy2::rx
Registered led device: b43-phy2::radio
b43-phy2 debug: Wireless interface started
b43-phy2 debug: Adding Interface type 2
ADDRCONF(NETDEV_UP): wlan0: link is not ready "

this is what /etc/init.d/network restart says "
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0...dhclient(1966) is already running - exiting. 

This version of ISC DHCP is based on the release available
on ftp.isc.org.  Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.

Please report for this software via the Red Hat Bugzilla site:
    http://bugzilla.redhat.com

exiting.
 failed.
                                                           [FAILED]
Bringing up interface wlan0:  
Determining IP information for wlan0... failed.
                                                           [FAILED]
"

Expected results:
It should work

Additional info:
Comment 1 hadmanysons 2008-09-12 01:14:21 EDT
Some how I fixed it. I erased all the file and directory of /lib/firmware/b43, removed the alias from modprobe.conf, restarted and started from scratch (for the bagilianth time) but somehow it worked this time. I don't know
Comment 2 John W. Linville 2008-09-12 09:06:37 EDT
Well I'm glad it is working.  My guess would be that somehow one of your firmware files got corrupted to cause the problem you observed.

Closing since it seems to be working...

Note You need to log in before you can comment on or make changes to this bug.