Bug 462086 - yum is much slower for _many_ excludes
yum is much slower for _many_ excludes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
Jan Hutař
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 11:02 EDT by James Antill
Modified: 2009-01-20 16:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:44:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-09-12 11:02:49 EDT
Description of problem:
 The 3.2.19 we have as an errata candidate for RHEL-5.3 has the following edge case bug we've just fixed upstream:

https://bugzilla.redhat.com/show_bug.cgi?id=461995

...the problem is that yum will always do some queries via. SQL now, however in some cases SQLite has performance problems. The bug above is for OLPC which is creating exclude lists with 2,200 packages in them, however:

time yum list $(perl -e 'print "python-urlgrabber " x 2200')

...will also hit the same problem.
 The speed difference is between ~2.5 seconds for a full repo. load, and upto 5 minutes for the above 2,200 package names. The fix isn't that complicated, so is viable.
 It's also worth noting that the speed drop is basically linear with the package list size, so if people are normally only doing 100-200 packages it'll only be a couple of seconds slower you.
Comment 1 RHEL Product and Program Management 2008-09-12 11:22:29 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 8 errata-xmlrpc 2009-01-20 16:44:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0176.html

Note You need to log in before you can comment on or make changes to this bug.