Bug 462088 - After latest updates my two rahide system have sound broken
After latest updates my two rahide system have sound broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
No sound with updated pulseaudio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 11:07 EDT by antonio montagnani
Modified: 2008-09-12 13:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 13:45:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/varlog/messages with pulseaudio/alsa issues (214.39 KB, text/plain)
2008-09-12 12:30 EDT, Tom London
no flags Details

  None (edit)
Description antonio montagnani 2008-09-12 11:07:15 EDT
Description of problem:
No sound after latest updates

Version-Release number of selected component (if applicable):
pulseaudio-0.9.12-5.fc10.i386

How reproducible:
always

Steps to Reproduce:
1.to play any stream, or check volume control, where on one system I have only Monitor/Playback of Null output
2.
3.
  
Actual results:
No sound available

Expected results:
It should have sound as before applying updates

Additional info:

Both system have a Intel sound card a 82801(ICH8) HD audio controller on the
laptop, and a 82801(ICH5/ICH5R) AC97 on the desktop.
Comment 1 Tom London 2008-09-12 12:30:31 EDT
Created attachment 316593 [details]
/varlog/messages with pulseaudio/alsa issues

I attach /var/log messages of a session showing several issues.

When I boot up to gnome, pulseaudio and helpers are running, but they die on "first use".

Included in the the attached log are:

Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)conf.c: Unknown parameters 0
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)pcm.c: Unknown PCM front:0
Sep 12 09:08:29 tlondon pulseaudio[3138]: alsa-util.c: Couldn't open PCM device front:0: Invalid argument
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)conf.c: Unknown parameters 0
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)pcm.c: Unknown PCM surround40:0
Sep 12 09:08:29 tlondon pulseaudio[3138]: alsa-util.c: Couldn't open PCM device surround40:0: Invalid argument
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)conf.c: Unknown parameters 0
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)pcm.c: Unknown PCM surround41:0
Sep 12 09:08:29 tlondon pulseaudio[3138]: alsa-util.c: Couldn't open PCM device surround41:0: Invalid argument
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)conf.c: Unknown parameters 0
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)pcm.c: Unknown PCM surround50:0
Sep 12 09:08:29 tlondon pulseaudio[3138]: alsa-util.c: Couldn't open PCM device surround50:0: Invalid argument
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)conf.c: Unknown parameters 0
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)pcm.c: Unknown PCM surround51:0
Sep 12 09:08:29 tlondon pulseaudio[3138]: alsa-util.c: Couldn't open PCM device surround51:0: Invalid argument
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)conf.c: Unknown parameters 0
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)pcm.c: Unknown PCM surround71:0
Sep 12 09:08:29 tlondon pulseaudio[3138]: alsa-util.c: Couldn't open PCM device surround71:0: Invalid argument
Sep 12 09:08:29 tlondon pulseaudio[3138]: (alsa-lib)pcm_hw.c: Invalid value for card
Sep 12 09:08:29 tlondon pulseaudio[3138]: alsa-util.c: Error opening PCM device hw:0: Permission denied
Sep 12 09:08:29 tlondon pulseaudio[3138]: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_27d8_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.

and

Sep 12 09:15:38 tlondon pulseaudio[3138]: module-stream-restore.c: Restoring device for stream sink-input-by-application-name:Pidgin.
Sep 12 09:15:38 tlondon pulseaudio[3138]: module-stream-restore.c: Restoring volume for sink input sink-input-by-application-name:Pidgin.
Sep 12 09:15:38 tlondon pulseaudio[3138]: sink.c: Assertion '!s->thread_info.rewind_requested' failed at pulsecore/sink.c:632, function pa_sink_render(). Aborting.


pulseaudio-utils-0.9.12-5.fc10.i386
pulseaudio-libs-0.9.12-5.fc10.i386
pulseaudio-0.9.12-5.fc10.i386
pulseaudio-esound-compat-0.9.12-5.fc10.i386
pulseaudio-libs-glib2-0.9.12-5.fc10.i386
pulseaudio-core-libs-0.9.12-5.fc10.i386
pulseaudio-module-gconf-0.9.12-5.fc10.i386
pulseaudio-module-x11-0.9.12-5.fc10.i386
Comment 2 antonio montagnani 2008-09-12 12:35:34 EDT
Found !!!

Please note that if I start the computer in level 5 I get this issue but if I start in level 5 and then I issue a startx it seems to have the sound back..
So it is not pulseaudio...but what???
Comment 3 antonio montagnani 2008-09-12 12:40:42 EDT
and I suppose that it does happens in a very spread way....my two cents...
Comment 4 sangu 2008-09-12 13:11:51 EDT
After updating gdm-2.23.92-4.fc10.i386 ( http://koji.fedoraproject.org/koji/buildinfo?buildID=62892 ), pulseaudio caches sound devices. 
This issue seems to be fixed in gdm-2.23.92-4.fc10.
Then, sound is mute(pcm is mute on alsa mixer of gnome-volume-control).
Comment 5 antonio montagnani 2008-09-12 13:18:32 EDT
I have only tje issue that capture in recording windows keeps to be disactivated every time I close the sound control window and I open it again....shall we move to a new bug???
Comment 6 Matthias Clasen 2008-09-12 13:45:40 EDT
Yes, lets close this one

Note You need to log in before you can comment on or make changes to this bug.