Bug 462241 - Red Hat 5.2 fails to boot after installing on IBM BladeCenter HS21 with multipathed boot-from-iSCSI with onboard NIC with NVRAM software initiator [NEEDINFO]
Red Hat 5.2 fails to boot after installing on IBM BladeCenter HS21 with multi...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.2
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Mike Christie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 13:54 EDT by Guy Rozendorn
Modified: 2014-06-02 09:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (guy)


Attachments (Terms of Use)

  None (edit)
Description Guy Rozendorn 2008-09-14 13:54:22 EDT
Description of problem:
After "successfully" installing Red Hat 5.2 on IBM HS21 Blade with boot-from-iscsi disk, the kernel panics and says it cannot find the root device.
Meaning, the installation fails altough anaconda said it was successful.
Therefore, I wrote "successfully".

Version-Release number of selected component (if applicable):
Don't remember the exact version, it is the version that comes with Red Hat 5.2


How reproducible:
I have an IBM BladeCenter HS21, with a blade which is connected to a SAN by iSCSI. I configured the iSCSI targets and the iSCSI initiator in the boot order, and booted from the Red Hat installation media.

At the boot prompt, I typed in linux text mpath asknetwork, and entered an IP addresses when the anaconda asked me to. It broght up the network interface, and successfully connected to the iSCSI target. 
At first, I saw the disk from the SAN device as /dev/sda, and then I pressed F2 and configured the second and third targets (for mulitipath). Then, I saw the device as /dev/mapper/mpath0 and chose install Red Hat on it (default partitioning layout, minimal package selection). 
After a few minutes, the installation will finished without error, but it will not boot.
  
Actual results:
The system fails to boot - kernel panic - fails to find root device

Expected results:
Boot normally

Additional info:
A quick look at the GRUB configuration shows that there's no initrd configured to load. so I mounted the disk on another linux host and saw that there's no /boot/initrd-2.6.18-92.el5.img at all! so I ran the installation again, and before it rebooted, I checked at /mnt/sysimage/boot for initrd, and it was there- meaning anaconda failed to create the initrd.
So I chrooted to /mnt/sysimage, and ran /sbin/mkinitrd - it screemed it cannot find /sbin/iscsistart, so i exited from the chroot and copied /usr/sbin/iscsi* to /mnt/sysimage/sbin. Then, I chrooted back in, ran mkinitrd again and it successfully created mkinitrd. the command I ran:
# /sbin/mkinitd /boot/initrd-`uname -r`.img `uname-r`
Then, I added "initrd /boot/inird-2.6.18-92.el5.img" to /boot/grub/grub.conf and rebooted the machine. Then, the system booted just fine.

So, what seems to happen is that anaconda failed to create the inird because of missing files regarding iscsi.
Then, I tried installing again, on the same blade and iSCSI device, this time without multipathing. Meaning, I ran at boot prompt: linux text asknetwork, installed redhat with default partitioning on /dev/sda, with minimal software packages. The installation ended, rebooted the system, and it loaded just fine without me having to create initrd manually.
The only difference between these two installations was the multipathing part, which is weird because the mkinird failed at the first time because of iscsi-related files, which were used also in the non-multipathed installation.

I repeated these two installations on several other Blades and iSCSI devices, and got the same behaviour. All blades used were with most-recent versions of BIOS and NIC firmwares.
Comment 1 Guy Rozendorn 2008-09-15 04:09:56 EDT
TYPO FOUND


> Additional info:
> A quick look at the GRUB configuration shows that there's no initrd configured
> to load. so I mounted the disk on another linux host and saw that there's no
> /boot/initrd-2.6.18-92.el5.img at all! so I ran the installation again, and
> before it rebooted, I checked at /mnt/sysimage/boot for initrd, and it WASN'T
> there- meaning anaconda failed to create the initrd.
Comment 2 RHEL Product and Program Management 2014-03-07 08:46:00 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:20:31 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.