Bug 462262 - xemacs cursor problems
xemacs cursor problems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 22:08 EDT by Horst H. von Brand
Modified: 2009-05-21 15:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-23 21:58:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-09-14 22:08:05 EDT
Description of problem:
xemacs loses the cursor sometimes: It just disapears, or gets replaced by a very thin red overline (cursor is a red rectangle), or even stays put while the "real" cursor moves around. This seems not to be xemacs' fault (oldish package, worked fine before), the closest xemacs-related install is xemacs-packages-extra

Version-Release number of selected component (if applicable):
xemacs-21.5.28-9.fc10.x86_64
xemacs-packages-extra-20070427-3.fc10.noarch

How reproducible:
Often (at least once an hour with my use here: mh-e with nmh, editing mostly LaTeX with auctex and C or C++ code).

Steps to Reproduce:
1. Hard to say, seems to be related to how long xemacs has been running.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Horst H. von Brand 2008-10-31 13:26:53 EDT
This seems to have dissapeared (really an X problem?)
Comment 2 Horst H. von Brand 2008-11-23 21:58:59 EST
Gone for good, together with other assorted X weirdness. Closing.
Comment 3 Mike Heffner 2009-05-21 10:29:13 EDT
This still appears to be a bug in:
Fedora release 9 (Sulphur)

with:

$ rpm -qa | grep xemacs
xemacs-packages-extra-20070427-2.fc9.noarch
xemacs-packages-base-20070427-1.fc8.noarch
xemacs-devel-21.5.28-6.fc9.x86_64
xemacs-21.5.28-6.fc9.x86_64
xemacs-common-21.5.28-6.fc9.x86_64


It is fairly easy to reproduce using Gnome as the WM:

- Open two files in different frames (python code for example).
- Use the Alt-Tab key-combination to switch between frames. Move the cursor
  around a bit and then switch back with Alt-Tab. The cursor will disappear even 
  though you can move around with the arrow keys and see the Line/Column numbers
  changing in the mode-line.
- Using the mouse to "click" in the other frame will bring the red cursor line
  back.

Any ideas? Currently unable to verify in F10.
Comment 4 Ville Skyttä 2009-05-21 14:12:36 EDT
I no longer have access to a F-9 box but just in case it has any effect (doubtful), a scratch build of 21.5.29 for F-9 is available at http://koji.fedoraproject.org/koji/taskinfo?taskID=1369044 in case you want to try it out.  If that doesn't fix it, it's very likely that F-9 will remain as is.
Comment 5 Mike Heffner 2009-05-21 15:16:11 EDT
(In reply to comment #4)
> I no longer have access to a F-9 box but just in case it has any effect
> (doubtful), a scratch build of 21.5.29 for F-9 is available at
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1369044 in case you want to
> try it out.  If that doesn't fix it, it's very likely that F-9 will remain as
> is.  

Nope, still a problem with 21.5.29. :-/

Guess I'll have to upgrade to F-10 at some point to try again.

Note You need to log in before you can comment on or make changes to this bug.