Bug 462317 - Update the vsftpd package due to fatal issue with Filezilla when SSL is used
Update the vsftpd package due to fatal issue with Filezilla when SSL is used
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Nagy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-15 06:56 EDT by George Notaras
Modified: 2016-07-26 19:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 18:15:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Notaras 2008-09-15 06:56:07 EDT
Description of problem:

Recent versions of FileZilla do not work with vsftpd when 'FTP over explicit SSL/TLS' is used to connect to the FTP server. The client gives the following error message:

  Status:	Server did not properly shut down TLS connection
  Error:	Could not read from transfer socket: ECONNABORTED - Connection aborted

According to the following pages:

  * http://trac.filezilla-project.org/ticket/3661
  * http://forum.filezilla-project.org/viewtopic.php?f=2&t=7688
  * http://vsftpd.beasts.org/

The issue is caused by the server, which does not seem to follow the standard way of closing the SSL connection.

This issue has been addressed in the 2.0.7 version of vsftpd.

Please update the package.

Affects both fedora releases 8 & 9 (and others possibly).


Version-Release number of selected component (if applicable):
vsftpd-2.0.5-20.fc8
vsftpd.2.0.6-4.fc9
Comment 1 Fedora Update System 2008-09-21 19:36:36 EDT
vsftpd-2.0.5-21.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/vsftpd-2.0.5-21.fc8
Comment 2 Martin Nagy 2008-09-21 19:40:46 EDT
The vsftpd package with the fix was submitted to updates-testing. I'd appreciate if you could test it and then add karma if it works for you, so that it can move to the stable repository.
Comment 3 George Notaras 2008-09-22 15:24:25 EDT
The vsftpd-2.0.5-21.fc8 release has resolved the problem and now users can normally connect to their ftp accounts using "FTPES - FTP over explicit SSL/TLS" without any error messages.

Thanks
Comment 4 Fedora Update System 2008-09-24 20:27:22 EDT
vsftpd-2.0.5-21.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vsftpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8368
Comment 5 Fedora Update System 2008-10-20 18:15:39 EDT
vsftpd-2.0.5-21.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.