Bug 462383 - sdcc 2.8.0's sdccman.lyx fails with 1.6.0rc3
sdcc 2.8.0's sdccman.lyx fails with 1.6.0rc3
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-15 16:10 EDT by Conrad Meyer
Modified: 2008-10-28 11:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 11:43:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Conrad Meyer 2008-09-15 16:10:28 EDT
Description of problem:
http://koji.fedoraproject.org/koji/getfile?taskID=821952&name=build.log

Version-Release number of selected component (if applicable):
1.6.0rc2


How reproducible:
Always.


Steps to Reproduce:
1. wget http://konradm.fedorapeople.org/sdccman.lyx
2. lyx -e text sdccman.lyx
3.
  
Actual results:
Error from iconv!


Expected results:
Success!


Additional info:
http://www.lyx.org/trac/changeset/26412 fixes the problem (I hope).
Comment 1 José Matos 2008-09-17 10:13:12 EDT
I do not see the error from iconv instead we hit an assert in the code. This is running rc2 in F-9 and rawhide.

The problem is fixed in the latest svn version, so it should be fixed with rc3 (soon to come).
Comment 2 Rex Dieter 2008-09-17 10:49:06 EDT
How soon?  I think a new build of sdcc is needed for f10-beta, and new builds are blocked until this gets fixed.

Otherwise, Conrad found the upstream commit that should fix this, I gave him our blessing to do a patched lyx build in the meantime.
Comment 3 José Matos 2008-09-17 11:24:12 EDT
(In reply to comment #2)
> How soon?

In less than a week. It depends also on how busy I am. :-)

> I think a new build of sdcc is needed for f10-beta, and new builds
> are blocked until this gets fixed.

OK.

> Otherwise, Conrad found the upstream commit that should fix this, I gave him
> our blessing to do a patched lyx build in the meantime.

Actually although I did not said that on the previous message I think that the guess is wrong. :-)
There are two issues involved and none is related with that patch. :-)

If a new lyx version is to be built I would suggest to package the current svn version as it works OK and it has several minor problems solved after rc2. My recommendation is done using the hat of (lyx) release manager.

The only difference between the current state and rc3 other than small fixes will be on translations.
Comment 4 Rex Dieter 2008-10-01 11:46:22 EDT
Still fails with rc3, but differenly.   

José, if you get a chance, can you take a peek?
http://koji.fedoraproject.org/koji/buildinfo?buildID=62815

I suppose it would be helpful to push this bug upstream, eh? :)
Comment 5 José Matos 2008-10-17 03:04:24 EDT
OK, I have pushed a fix while discussing this at lyx devel list.

Meanwhile I have ignored lyx warnings and I make the pdf using lyx, there is no need to do it by hand (and it was failing for me).
Comment 6 Conrad Meyer 2008-10-17 03:08:32 EDT
I noticed the fix -- thanks. I'm glad to have sdcc 2.8.0 building.
Comment 7 Conrad Meyer 2008-10-27 20:39:08 EDT
Is this fixed now (can we close it)?
Comment 8 José Matos 2008-10-28 09:32:18 EDT
The problem at hand was fixed.

It would be interesting to push upstream both patches. Although the "|| echo ..." part is not needed anymore as the bug that triggered that scenario has been fixed and the fix is already present in lyx-1.6.0 rc4.
Comment 9 Conrad Meyer 2008-10-28 11:43:21 EDT
Great, thanks. Closing.

Note You need to log in before you can comment on or make changes to this bug.