Bug 462428 - XML domain file should add an extra args tag
XML domain file should add an extra args tag
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All All
medium Severity low
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 03:31 EDT by Toniob
Modified: 2010-03-16 13:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 06:11:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toniob 2008-09-16 03:31:52 EDT
It's not a bug, it's a feature ... request.

I think that the xml file describing a domain should add a new tag to add extra arguments to the command line (especially for kvm, I don't know xen). It will be possible to use some kvm options even if libvirt don't use them (yet). For example, using the -mem-path option in kvm as libvirt doesn't recognize it.

I suggest <args value="some extra args" />

Will it be possible?

Thanks
Comment 1 Daniel Veillard 2008-09-23 06:11:40 EDT
Not possible. The XML format will expose only options that are
understood by libvirt. This has been explained many time on the
mailing-list, and the only way to avoid exposing hypervisor specifics
into user configs. The goal of libvirt is to abstract from the hypervisor
specifics, opening up the format like you suggest is against the core
goal of libvirt.

Daniel

Note You need to log in before you can comment on or make changes to this bug.