Bug 46245 - rpm --verify bind complains about /etc/rndc.conf
Summary: rpm --verify bind complains about /etc/rndc.conf
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bind   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-27 15:14 UTC by Jonathan Kamens
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-27 15:14:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2001-06-27 15:14:36 UTC
When I run "rpm --verify bind" with bind-9.1.3-0.rc2.1 installed, I see
"S.5....T c /etc/rndc.conf".  I shouldn't see this complaint, since there's
nothing wrong with the fact that /etc/rndc.conf has been modified, since
it's a config file which frequently gets modified after installation.

Comment 1 Bernhard Rosenkraenzer 2001-06-27 15:23:15 UTC
It's the correct behavior nevertheless. rpm --verify shows which files have 
changed. It does not necessarily indicate a problem. (Yes, rpm --verify apache 
shows modifications in httpd.conf, as well).

The reasoning is that it makes sense to get a list of modified files - someone 
who edited a file will know about it, and know it's not a problem that the 
file has changed.
However, if you know you never touched a file, you can see if it has been 
modified by something else (e.g. cracker, filesystem corruption). It also 
helps consultants and support to find out what files their customer edited.



Note You need to log in before you can comment on or make changes to this bug.