Bug 462452 - RHEL4 HA LVM setup check error messages not being fully displayed
RHEL4 HA LVM setup check error messages not being fully displayed
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 09:23 EDT by Shane Bradley
Modified: 2010-10-23 00:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:13:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes issue (1.43 KB, patch)
2008-09-16 09:24 EDT, Shane Bradley
no flags Details | Diff

  None (edit)
Description Shane Bradley 2008-09-16 09:23:45 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

Creating an lvm cluster service and then "touching" lvm.conf will throw and error, however error is not completely displayed.If /etc/lvm/lvm.conf is newer than the lvm.conf in the initrd image than error is thrown. 

However, the full error message is not shown.
The reason is that the "-" in the error message is preventing the message from being displayed. 

The file that error message is coming from is:
/usr/share/cluster/lvm.sh:ha_lvm_proper_setup_check

Removing the "-" fixes the issue. A patch will be uploaded that fixes the issue. There is more than one place where this issue occurs and all have been resolved with patch. The patch has been tested and verified by recreation.

Reproducible: Always

Steps to Reproduce:
1.Setup cluster and ha lvm service via http://kbase.redhat.com/faq/FAQ_96_12831.shtm
2.verify lvm works service works
3.$ touch /etc/lvm/lvm.conf
4.$ cat /var/log/messages
Actual Results:  
The full error message is not displayed. The only error message is:
clurgmgrd: [5722]: <err> HA LVM:  Improper setup detected

Expected Results:  
The full error message should be displayed:
clurgmgrd: [5722]: <err> HA LVM:  Improper setup detected
clurgmgrd: [5722]: <err> initrd image needs to be newer that lvm.conf
Comment 1 Shane Bradley 2008-09-16 09:24:44 EDT
Created attachment 316849 [details]
Patch that fixes issue
Comment 3 Lon Hohberger 2008-12-03 12:01:23 EST
Same bug as this one:

https://bugzilla.redhat.com/show_bug.cgi?id=471431

Worth fixing; it's easy to fix and such; not been ported to RHEL4 branch yet.
Comment 4 Lon Hohberger 2008-12-09 15:59:01 EST
Comment on attachment 316849 [details]
Patch that fixes issue

Merged patch from RHEL5 branch instead:

http://git.fedorahosted.org/git/?p=cluster.git;a=commit;h=a42cdd513637c80573fe883d5dc9ec9c207f9f1e
Comment 7 errata-xmlrpc 2009-05-18 17:13:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1048.html

Note You need to log in before you can comment on or make changes to this bug.