Bug 462476 - RuntimeError: Error running dumpe4fs: No such file or directory
RuntimeError: Error running dumpe4fs: No such file or directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
medium Severity medium
: beta
: ---
Assigned To: Anaconda Maintenance Team
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 11:50 EDT by Jeff Burke
Modified: 2009-01-20 16:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:35:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-09-16 11:50:52 EDT
Description of problem:
* RHEL5.3-Server-20080916.nightly
* Error appears through automate RHTS testing
* Behavior appears arch independent

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20080916.nightly

How reproducible:
Always

Steps to Reproduce:
1. Try a nfs install from pxe with a ks.cfg file
  
Actual results:
Running anaconda, the Red Hat Enterprise Linux Server system installer - please wait...
Probing for video card:   Unable to probe
No video hardware found, assuming headless
Running pre-install scripts
Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 72, in execWithCapture
    raise RuntimeError, "Error running " + command + ": " + msg
  File "/usr/lib/anaconda/fsset.py", line 3206, in getExtFSFlagsFeatures
    output = iutil.execWithCapture("dumpe4fs", args, stderr = "/dev/tty5")
  File "/usr/lib/anaconda/fsset.py", line 784, in probe
    flags, features = getExtFSFlagsFeatures(device)
  File "/usr/lib/anaconda/partedUtils.py", line 487, in sniffFilesystemType
    if fsset.ext4devFileSystem.probe(dev):
  File "/usr/lib/anaconda/partitions.py", line 409, in setFromDisk
    fs = partedUtils.sniffFilesystemType("/dev/%s" % device)
  File "/usr/lib/anaconda/partitioning.py", line 53, in partitionObjectsInitialize
    anaconda.id.partitions.setFromDisk(anaconda.id.diskset)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 223, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/cmdline.py", line 130, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/bin/anaconda", line 1003, in ?
    anaconda.intf.run(anaconda)
RuntimeError: Error running dumpe4fs: No such file or directory

install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system


Expected results:


Additional info:
Comment 1 Eric Sandeen 2008-09-16 12:06:25 EDT
It appears that dumpe4fs just needs to be available to anaconda in this install scenario (it is part of the e4fsprogs rpm)
Comment 3 Radek Vykydal 2008-09-16 12:14:21 EDT
Caused by e4fsprogs missing in the tree.
AFAIK, the package has been tagged and added already,
so it should be fixed in next build.
Comment 7 Denise Dumas 2008-09-16 13:56:12 EDT
per Chris: dumpe2fs (and possibly other programs) need to be added to the list in KEEPFILE in scripts/upd-instroot
Comment 8 Chris Lumens 2008-09-16 14:15:43 EDT
These program should be included in anaconda-11.1.2.124-1.  We will, unfortunately, need another tree in order to test that out.
Comment 12 Brock Organ 2008-09-17 10:00:18 EDT
hmmm ... I think this issue is still open, unfortunately:

RHEL5.3-Server-20080917.nightly is still showing this problem, even though it has 
anaconda-11.1.2.124-1 in it ...

Here's an example case showing the error:

http://hank.test.redhat.com/kate/auto.cgi?action=case&group=nightly_RHEL5.3-Server-20080917.nightly_5-x86_64&case=minimal-distill-yes-yes-english-nfs-noipv6-VNC

for the next few hours, if its helpful, I'll leave this install up and available for devel to connect to:

$ vncviewer test187.test.redhat.com:1
Comment 13 Chris Lumens 2008-09-17 10:22:55 EDT
My apologies, the correct version of anaconda that includes this fix is anaconda-11.1.2.125-1.  I built shortly after updating the bug and must have grabbed the version out of the spec file before I bumped it for the rebuild.  If you can do another compose, that should clear this up.
Comment 16 errata-xmlrpc 2009-01-20 16:35:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html

Note You need to log in before you can comment on or make changes to this bug.