Bug 462497 - picttoppm missing from netpbm package
picttoppm missing from netpbm package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 14:23 EDT by Penelope Fudd
Modified: 2013-07-02 19:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 08:22:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Penelope Fudd 2008-09-16 14:23:00 EDT
Description of problem:
I had to convert a pict file, and was surprised to not find picttoppm, even though ppmtopict was present.

Version-Release number of selected component (if applicable):
netpbm-progs-10.35.48-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. yum -y install netpbm-progs
2. which picttoppm
3. man picttoppm
4. which ppmtopict
5. man ppmtopict
  
Actual results:
picttoppm: Command not found.
No manual entry for picttoppm
/usr/bin/ppmtopict
Ppmtopict User Manual...(with SEE ALSO: picttoppm)

Expected results:
/usr/bin/picttoppm
Picttoppm User Manual...
/usr/bin/ppmtopict
Ppmtopict User Manual...

Additional info:
I didn't check for other missing files, but I did download the svn version of the upstream package.  picttoppm is present.
svn checkout https://netpbm.svn.sourceforge.net/svnroot/netpbm/advanced netpbm
Comment 1 Jindrich Novy 2008-09-18 08:22:19 EDT
Yes, the picttoppm.c is present among netpbm sources, but upstream decided to drop this utility because it is, in their words, unfixable. The first line of ppmtopict.c says:

#error "Unfixable. Don't ship me"

If you are still interested in the utility, please ask upstream to readd it.

Note You need to log in before you can comment on or make changes to this bug.